Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Unhappy Weird Vibration on RXP

    Hello, everyone.

    I have bought two 2004 RXPs this spring, been using them in fresh water for 30~ hours.
    recently one of the skis started to vibrate. I woundt say big vibration, similar to 2-stroke working vibration. Its highly noticable at 5000rpms.
    even more its noticable when releasing throtle from Wot to 5000rmps.
    I have checked wear ring, do not have anything in pump jammed, i, also, didnt jam anything prior to vibration appearance.
    I checked the other ski and its running very different and no vibration at all. I have swaped pumps on the skis to check if it makes difference, it didnt. still that vibration and strange sound. maybe from engine maybe from ratling caused by vibration.
    I dont have delaer anywhere near. in my country PWC market was born last year, so this board is my only chance.
    WHere to start loocking for troubles? what to check step by step?

    thanks in advance guys.

    Den


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,397
    +1
    2,524
    Welcome to the forum!

    You could have a bent blade on your impeller. Also, check for a broken motor mount. Specifically the front one.

  3. #3
    Quote Originally Posted by Green Hulk
    Welcome to the forum!

    You could have a bent blade on your impeller. Also, check for a broken motor mount. Specifically the front one.

    Thanks for fast reply.

    I dont think blade is bent, as I have swaped the entire pump from "non-vibrating" ski to see if it makes difference. it didnt. Plus, i didnt catch anything in the intake that day. ONly thing I was doing is playing with ski tight turns, circles.. could that damage the mounts?

    How do I know if the motor mount is broken? Should it be obviously cracked or something else?

  4. #4
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,884
    +1
    496
    IMO I would replace the front engine mount on both of your skis if they have very many hours on them at all

  5. #5
    Quote Originally Posted by oklagp1200r
    IMO I would replace the front engine mount on both of your skis if they have very many hours on them at all

    how hard is it to swap the mounts to see if thats the deal?
    Can I do it without engine allighnment tool?

    both skis are like 50 hours or so.

  6. #6
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,884
    +1
    496
    Loosen the front mount have a buddy lift the front of the engine slid old one out then slid new one in that simple! No alignment tool needed IMO

  7. #7
    Quote Originally Posted by VenomRXP
    how hard is it to swap the mounts to see if thats the deal?
    Can I do it without engine allighnment tool?

    both skis are like 50 hours or so.
    50 hours , I would think you would have to run them pretty damn hard to bust a mount that young!...PR...

  8. #8
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    Something else to atleast consider, Maybe and I said maybe a rod bolt is starting to back out. I dont want to scare you but I had an unexplained vibration on my 04 rxp. I didnt pin point it until I had a catastrophic failure. FYI the only way to check this is to pull the motor and crack the cases.

  9. #9
    Quote Originally Posted by Pale Rider
    50 hours , I would think you would have to run them pretty damn hard to bust a mount that young!...PR...
    Exactly! No hard driving at all. more over, almost no wakes or chop on our rivers. But just to eliminate possibility I'd check that.

  10. #10
    Quote Originally Posted by Insanediego-RXP
    Something else to atleast consider, Maybe and I said maybe a rod bolt is starting to back out. I dont want to scare you but I had an unexplained vibration on my 04 rxp. I didnt pin point it until I had a catastrophic failure. FYI the only way to check this is to pull the motor and crack the cases.
    You did scare me
    but its better to be scared knowing what it could be.

    Is there a way to check if the vibration is from the engine or from the driveline?
    Can that be supercharger clutch going? they are still stock ceramics...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. weird beep on rxp
    By Chezzy in forum 4-Tec Performance
    Replies: 9
    Last Post: 11-27-2006, 08:25 PM
  2. 10 Hrs. on RXP oil change??
    By RXPNJ in forum 4-Tec Performance
    Replies: 18
    Last Post: 09-09-2006, 08:55 AM
  3. Riva Pricing on RXP and RXT
    By jack in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 06-24-2005, 03:26 PM
  4. 1 year old on RXP.
    By Thomas in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-31-2005, 01:38 PM
  5. sound improvment (louder) on RXP ?
    By mrracing in forum 4-Tec Performance
    Replies: 23
    Last Post: 05-05-2005, 05:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •