Results 1 to 4 of 4
  1. #1
    mike1706's Avatar
    Join Date
    Dec 2008
    Location
    ,Florida
    Posts
    1,691
    +1
    16

    need to clean my connectors where the efi goes

    Please i need some help. I need to clean my connectors. I have a EFI and the two connector are sulfate they are green. what should i do.


  2. #2

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9

    Cool

    and this is on the main ecu?


    cd

  3. #3
    buy a can of contact cleaner, then use dielectric grease when putting the plugs back together once you have them clean

  4. #4
    mike1706's Avatar
    Join Date
    Dec 2008
    Location
    ,Florida
    Posts
    1,691
    +1
    16
    yeah it come from the main ecu, yeah but should i spray CRC ELECTRONIC CLEANER on the connector and then spray somer air and you think it will clean everything.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Do I need to start my seadoo to use the candoo pro
    By travis ingram in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-09-2015, 05:39 PM
  2. Gaskets/O-Rings Needed To Clean The Intercooler On A 300X
    By Speed Jones in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 07-13-2012, 02:51 AM
  3. Do I need to clean the exhaust chamber
    By kcc0521 in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 03-19-2011, 08:31 AM
  4. Replies: 9
    Last Post: 08-31-2010, 07:31 PM
  5. Do i need to cahnge my wear ring?
    By Totallyblown in forum 4-Tec Performance
    Replies: 1
    Last Post: 11-21-2005, 05:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •