Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 57
  1. #1
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113

    coolant leak.....from where?

    I seem to have a pretty bad coolant leak and just can't seem to find where it is. Josh took my ski out couple weeks ago to do some testing and he said there was a lot of coolant in the hull. so we added a little and he did another pass and the bottle was empty again. I took off the thermo housing and found one of the plastic feet things was broken and created a bad seal. so i thought i had it fixed, i smoothed it all out and put it back together. tested the ski yesterday after adding the coolant and everything seemed good. i did a couple passes and coolant went doen just a little. So today i took it out to test out my new prop from Speedfreeks and i did a bunch of passes ski ran great. came back to the beach and the coolant bottle is empty again and coolant is inside the hull!!!! it only seems to do it once the ski gets real hot and after doing a bunch of speed passes. anyone know where it could be coming from?


  2. #2
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    Quote Originally Posted by rxpblast View Post
    I seem to have a pretty bad coolant leak and just can't seem to find where it is. Josh took my ski out couple weeks ago to do some testing and he said there was a lot of coolant in the hull. so we added a little and he did another pass and the bottle was empty again. I took off the thermo housing and found one of the plastic feet things was broken and created a bad seal. so i thought i had it fixed, i smoothed it all out and put it back together. tested the ski yesterday after adding the coolant and everything seemed good. i did a couple passes and coolant went doen just a little. So today i took it out to test out my new prop from Speedfreeks and i did a bunch of passes ski ran great. came back to the beach and the coolant bottle is empty again and coolant is inside the hull!!!! it only seems to do it once the ski gets real hot and after doing a bunch of speed passes. anyone know where it could be coming from?

    Gun did u look at the over flow tube on the coolant bottle itself.....some people over look the fact its just coming right out of there and if so its most likely your BLOWN head gasket is pressurizing your coolant system! BET!

  3. #3
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    Quote Originally Posted by REID2168 View Post
    Gun did u look at the over flow tube on the coolant bottle itself.....some people over look the fact its just coming right out of there and if so its most likely your BLOWN head gasket is pressurizing your coolant system! BET!
    man i never thought of that, i will go take a look and see if it came out of there. whats a way to actually test a blown head gasket?

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    +1 on reid's comment.

    Probably a blown head gasket and probably the reason Josh assumed your Riva catch can was garbage in this post
    http://greenhulk.net/forums/showpost...28&postcount=4
    and the reason you were spewing oil everywhere


    Another scenario is you could have your coolant lines crossed on the thermostat. Follow the hose coming from your over flow tank and make sure it's on the forward most fitting on the side of the thermostat. I see many people put it on the rear most fitting and the oil cooler hose onto the front fitting and when this happens you will spew out coolant under hard acceleration.

    Also, if this is the case then you were getting a slight overheat of the oil and that's the reason your "garbage" catch can was spewing oil

  5. #5
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    Quote Originally Posted by rxpblast View Post
    man i never thought of that, i will go take a look and see if it came out of there. whats a way to actually test a blown head gasket?

    dont know of a TEST but i know if u got coolant coming from that bottle over flow tube under a load its over for that head gasket and it needs to be changed...especially IF your lines are hooked up properly .....use Permatex copper coat when u do it Bro! good luck my man!

  6. #6
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    Quote Originally Posted by Green Hulk View Post
    +1 on reid's comment.

    Probably a blown head gasket and probably the reason Josh assumed your Riva catch can was garbage in this post
    http://greenhulk.net/forums/showpost...28&postcount=4
    and the reason you were spewing oil everywhere


    Another scenario is you could have your coolant lines crossed on the thermostat. Follow the hose coming from your over flow tank and make sure it's on the forward most fitting on the side of the thermostat. I see many people put it on the rear most fitting and the oil cooler hose onto the front fitting and when this happens you will spew out coolant under hard acceleration.

    Also, if this is the case then you were getting a slight overheat of the oil and that's the reason your "garbage" catch can was spewing oil
    I didn't call it a garbage catch can haha. the oil in the hull was my fault and not a big deal at all. i reach in the front of the motor for something and must have bumped the petcock open so it just drained. but looking at the catch-can after today its not bad at hull there is fluid in there but didn't spew out all over.

  7. #7
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    Quote Originally Posted by REID2168 View Post
    dont know of a TEST but i know if u got coolant coming from that bottle over flow tube under a load its over for that head gasket and it needs to be changed...especially IF your lines are hooked up properly .....use Permatex copper coat when u do it Bro! good luck my man!
    Sounds like i have some work to do. man that head gasket didn;t last long!

  8. #8
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    Quote Originally Posted by rxpblast View Post
    Sounds like i have some work to do. man that head gasket didn;t last long!

    Dude sometimes thats the nature of the GAME................it SUCKS A$$ but it happens to everybody and dont let anyone tell u different........... PERMATEX COPPER COAT..............in this particular case its like your DOG............mans BEST FRIEND!!!!!!!!!!!!............ hahahahahahahaha.............. handle it Homey!!!!!!!!!!!!!!!

  9. #9
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    does the ski run any different when the head gasket goes? like rpms or anything? just more couirous then anything. i will be getting on this very soon!

  10. #10
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    Quote Originally Posted by rxpblast View Post
    does the ski run any different when the head gasket goes? like rpms or anything? just more couirous then anything. i will be getting on this very soon!

    if it were injesting/pulling coolant into the cylinders it would lose rpm's more often then not BUT in your case its most likely pressurizing the coolant system...... so its BLOWING combustion/exhaust into the cooolant system........ JUST ENOUGH to cause it to pressurize & over flow/puke coolant into the hull......a VERY SMALL pin blow out can cause this easily................... get it fixed!

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help.. Coolant leaking from pump tunnel
    By jhill19 in forum 4-Tec Performance
    Replies: 18
    Last Post: 03-18-2011, 10:51 AM
  2. got a water leak today cant seem to find from where
    By wave15stx in forum Yamaha PWC Performance (4-stroke)
    Replies: 20
    Last Post: 09-09-2010, 02:42 AM
  3. HELP! Oil leaking from where midshaft connects to engine.
    By o uncola o in forum Conversion PWC Performance Skis
    Replies: 8
    Last Post: 08-10-2010, 12:07 PM
  4. so i have a exhaust leak in my 03 gp800r i think i found from where
    By 98gsxl951 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 04-14-2010, 10:39 AM
  5. coolant leak from rideplate rubbers and 2 torxheads
    By baba850r in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-26-2009, 04:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •