Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30
  1. #1
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,248
    +1
    62

    ??????? 07 rxp ????

    Guys I was doing 81 @8100with stock ECU now yesterday I install the riva ECU and my max speed is 77mph @8380 wtf happen . maybe because I have not agrade my springs?


  2. #2
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    just curious...Did you think they were lying when the said the valvetrain upgrade is necessary ?

  3. #3
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    i had my X running 77 with the stock ecu and added the Riva and my boat picked up 200 rpm's and went 79 without touching a thing.........u have a problem and its not the valve train.....YET...........u need retainers OR springs/retainers depending style used to go past 8400 BUT its still got a problem somewhere else u need to address first since it should not have SLOWED .......as long as u stay under 8400 for now your good with stock valve train...rev it past that and u may be in trouble...FLAT WATER for now..good luck!

  4. #4
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Floating da valves.....

  5. #5
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,248
    +1
    62
    Quote Originally Posted by REID2168 View Post
    i had my X running 77 with the stock ecu and added the Riva and my boat picked up 200 rpm's and went 79 without touching a thing.........u have a problem and its not the valve train.....YET...........u need retainers OR springs/retainers depending style used to go past 8400 BUT its still got a problem somewhere else u need to address first since it should not have SLOWED .......as long as u stay under 8400 for now your good with stock valve train...rev it past that and u may be in trouble...FLAT WATER for now..good luck!
    REID I have 250 hours on the ski I think thas to many hours dont you think?

  6. #6
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,248
    +1
    62
    Quote Originally Posted by mrbtd View Post
    just curious...Did you think they were lying when the said the valvetrain upgrade is necessary ?
    no but i was curious

  7. #7
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    Quote Originally Posted by rxpredviper View Post
    REID I have 250 hours on the ski I think thas to many hours dont you think?

    i wont deny thats a lot of hours friend but your boat revved up .......... if u were running 8100ish and now u revved to 8300ish thats exactly what i would expect from the MOTOR without touching a thing and adding ONLY a Riva ecu......now running so much slower with more rpm's makes me feel your dragging a DEAD BODY but i cant see that far brotha......look under the boat....seriously something is wrong besides the engine if u ask me....hope u find it bro!

  8. #8
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,248
    +1
    62
    Quote Originally Posted by REID2168 View Post
    i wont deny thats a lot of hours friend but your boat revved up .......... if u were running 8100ish and now u revved to 8300ish thats exactly what i would expect from the MOTOR without touching a thing and adding ONLY a Riva ecu......now running so much slower with more rpm's makes me feel your dragging a DEAD BODY but i cant see that far brotha......look under the boat....seriously something is wrong besides the engine if u ask me....hope u find it bro!
    the prop i have is a 15/22+1mm
    and the rpm are 8380 and 14 pound of boost with riva S/C port. the motor is go I think.

  9. #9
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,248
    +1
    62
    Quote Originally Posted by jtskier11 View Post
    Floating da valves.....
    thas what i it is

  10. #10
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    Quote Originally Posted by rxpredviper View Post
    thas what i it is

    they could be flaoting with 250 hour old stock springs yes BUT they say u can rev these engine to 8300+ with the SEA DOO CENTRE reflash........ so whats the difference if hes only at 8380 rpm regardless of the ecu brand.............they shouldnt be floating....not saying they arent just saying it doenst sound right to me with the engine rpm increase!

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 07 rxp's
    By skillet in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-14-2006, 02:10 AM
  2. 07 rxp's
    By skillet in forum 4-Tec Performance
    Replies: 8
    Last Post: 10-17-2006, 11:39 PM
  3. 07 RXP
    By gotpurp305 in forum 4-Tec Performance
    Replies: 11
    Last Post: 10-04-2006, 03:51 PM
  4. 07 RXPs look like they were made by playskool
    By excess in forum 4-Tec Performance
    Replies: 11
    Last Post: 09-18-2006, 12:25 AM
  5. 07 rxp colors
    By sabor in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 06-15-2006, 08:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •