Results 1 to 4 of 4
  1. #1

    2002 Virage meter not working

    2002 Virage that my meter quit all together. it was working fine then nothing. not sure if its a wire or what. its a digital meter. is there a way i could hook up a battery to it to see if it works. im not sure which wires i could hook it up to. dont want to blow anything up.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    There is a 2 Amp fuse for the MFI display.

    It is tucked inside a wire splice connection near the battery area. There may be a white label on the outside. Un-clip the cover, and check the fuse inside.

    There is also a 3 Amp bilge fuse nearby.

    If the fuse is good, the next step is to check for battery power at the 12-pin connector behind the display. Touch a voltmeter to the Black and Red/Purple (or Red/White) wires on the connector. Pins 2 and 3.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	P5200022.JPG 
Views:	60 
Size:	2.62 MB 
ID:	152169  

  3. #3
    on my machine i dont see any fuse whats so ever like shown in the photo. however i did check voltage at the meter with black and red/purple wire and i get 10 volts. i disconnected the harness to the meter and applied battery voltage and it did work. now im really confused. also dont understand why i dont have a 3amp fuse like shown in the pic.

  4. #4
    dghal's Avatar
    Join Date
    Jul 2008
    Location
    League City Texas
    Posts
    280
    it should be there

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GP1300r Multifunction meter not working
    By Mdolphin in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 05-14-2014, 10:58 PM
  2. HELP!!! 2004 polaris virage speedometer not working
    By twoslow in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-01-2013, 09:46 AM
  3. 2006 VX110 Sport Multifuntion Meter not Working
    By JukeboxRob in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 06-13-2013, 07:05 PM
  4. 2002 virage will not start
    By DuffBeer4U in forum Polaris Open Discussion
    Replies: 2
    Last Post: 04-19-2012, 10:46 PM
  5. 2002 Virage will not crank or bilge pump
    By anniewf in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-09-2011, 06:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •