Results 1 to 6 of 6
  1. #1
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6

    MFD reset works!

    Hey gang, just going over the ski for tomm's run. I "reset" the MFD according to these instructions I recieved on GH!. I forgot who though. Maybe it was 447. Anyways. Thanks. It worked perfect.
    And the volts are on the screen saying 14.1 volts. So I guess me running out on the lake last weekend brought the battery up to snuff! When I cylcle thru the options, it goes thru them all. so it's working perfect!. Hours says 93.1 Thank God,,they are 450.00 new, lol .
    Now my other MFD needs some help. The dog had it's paws all over that one while riding and I think the led screen is hit. Not to mention all the paint on it is off. Whose the guys on here who wanted a working mfd to fix? I remember someone talking about it. I need this one fixed.



    MFD reset;
    You may need to first touch the Mode button to wake up the MFD
    Press and hold the MODE and SET buttons until CAL 0000 displays. The CAL display will usually show after 4 seconds
    Release both buttons?
    Press and hold the SET key
    While continuing to hold the SET key and within 2 seconds of pressing the SET key, press and hold the MODE key
    Don't release either key until the MFD shuts down (about ten seconds).
    After the MFD has shut itself down, press the mode key to turn the MFD on
    Depress the MODE key repeatedly until voltage is displayed and verify that the voltage reading has been restored.
    Speculation on my part;
    This procedure may only work when the MFD is plugged into a complete ski, if the MFD needs to see certain voltages on pins other than power and ground. I don't recall if it worked properly on my work bench.


  2. #2
    Buy American or Learn To Read This: >^$"#[email protected]*$:?</
    Join Date
    Jun 2009
    Location
    Glendale, Az
    Posts
    267
    Cool Info. I will have to keep it handy, just in case. Thanks!

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Battery should only read 12.6V if it's not running. 14-14.5 if it is......

    Use a volt meter amd place it across the battery posts to verify battery voltage.

  4. #4
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    That was 14.1v running! Yeah it is good info that mfd reset. Just copy n paste it in your POLARIS folder on your computer. Easy acess if needed. I'll check it with a meter too. Just to check.

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    If that was running, then your ALL GOOD!!!!!!!!

  6. #6
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    Off to the lake! Just checked volts across batt. 12.5 v.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 sl900 mfd not working
    By bodefan08 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-18-2009, 11:26 AM
  2. 96 SLT 780 MFD not working
    By rc3477 in forum Polaris Open Discussion
    Replies: 14
    Last Post: 06-12-2009, 08:03 PM
  3. mfd not working...help please
    By sl75 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 03-17-2009, 08:13 PM
  4. MFD Reset/Wont come on
    By seaobin in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-01-2007, 04:40 AM
  5. mfd not working
    By LANCE in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 05-28-2007, 10:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •