Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    95spi w\factory pipe/96xp Diggler's Avatar
    Join Date
    Sep 2009
    Location
    Lake Saint Clair Michigan
    Posts
    132

    Swaped the mpem/cdi box on 787

    I posted this question before. Only got the "you have to take it to a dealership to get the dess coded" I know, I bought it with a key from Seadoo scource. Has anyone done this before and know that it is a rule of thumb to also take it there to confirm that the timing is ok. My tech buddy at my local seadoo shop said it is set pretty standard and "should" be ok. I would like to know from you guys considering the staor on 787's is not adjustable and the mpem stores timing information. Also hense my trouble before was the 5 amp fuse on the mpem blowing. I Did read the thread about the inductive short occuring in the stator box from the metal shavings or wear from your starter and fly weel. I cleaned it well with carb cleaner and the blow gun/air compressor. Im running a faster top speed than before but notice a small miss fire when not at wot and just cruising on plane around 4000 or maybe 30mph or so. I need a tiny tach as well on this thing. I did have some down time waiting for my parts so I cleaned little flashingings and roughness out or off the inside walls of the expansion chamber part of the tuned pipe, nothing major, just smoothed it out. Also do power valves stick and not open up in some cases then mysteriously go away?
    Last edited by Diggler; 09-28-2009 at 07:02 PM.


  2. #2
    95spi w\factory pipe/96xp Diggler's Avatar
    Join Date
    Sep 2009
    Location
    Lake Saint Clair Michigan
    Posts
    132

    Swaped the mpem/cdi box on 787

    There ya go slipnot! no feedbad! sorry ive said anything to your post, Im only trying to help or recieve help adice , considering I had the same problem or identical problem. thoe yours is a 717, I didnt read that until later in the thread.

  3. #3
    slipnot's Avatar
    Join Date
    Jul 2009
    Location
    Michigan
    Posts
    153
    +1
    1
    What year and model is your 787? Typically when you swap MPEMs you have to reprogram the DESS...we are talking dealer here. That is just what I have read in other forums. Don't know if that helps or not.

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    check your grounds...you may have some corrosion. check the ground on the bottom of the motor. that may be your problem

  5. #5
    95spi w\factory pipe/96xp Diggler's Avatar
    Join Date
    Sep 2009
    Location
    Lake Saint Clair Michigan
    Posts
    132

    Swaped the mpem/cdi box on 787

    please dont respond any 2 pennys to this post about the Digital Encoded secerety system or "DESS"!!!!! totally not my question. I am talking about something totally different with the mpem and timing.

  6. #6
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by Diggler View Post
    please dont respond any 2 pennys to this post about the Digital Encoded secerety system or "DESS"!!!!! totally not my question. I am talking about something totally different with the mpem and timing.
    im not talking about the DESS or the MPEM.

  7. #7
    95spi w\factory pipe/96xp Diggler's Avatar
    Join Date
    Sep 2009
    Location
    Lake Saint Clair Michigan
    Posts
    132

    Swaped the mpem/cdi box on 787

    No I wasnt saying that to you airbornexp you have good prior advice and have helped me. Good point though on the grounds. Maybe something to do with the slight miss fire when not at WOT. Is the timinng checked from the factory and are all stock mpem's for a 787 programmed all at the same number? Id figure every engine would have a slight difference to be corrected with the programmer to be set correct.

  8. #8
    slipnot's Avatar
    Join Date
    Jul 2009
    Location
    Michigan
    Posts
    153
    +1
    1

    Adios

    Diggler you gotta chill MAN. I was just trying to help! Airborne I gave him some information I guess it wasn't what he wanted. Good luck Diggler.

  9. #9
    Rebcammaz's Avatar
    Join Date
    Mar 2009
    Location
    Brick, NJ
    Posts
    95
    Ive changed a few mpems on sea doos and the timing should be fine as long as its the same part number,and same model ski, and ive never had a problem.

  10. #10
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by Diggler View Post
    No I wasnt saying that to you airbornexp you have good prior advice and have helped me. Good point though on the grounds. Maybe something to do with the slight miss fire when not at WOT. Is the timinng checked from the factory and are all stock mpem's for a 787 programmed all at the same number? Id figure every engine would have a slight difference to be corrected with the programmer to be set correct.
    Quote Originally Posted by Rebcammaz View Post
    Ive changed a few mpems on sea doos and the timing should be fine as long as its the same part number,and same model ski, and ive never had a problem.
    +1 Ive burned my share of MPEM's and I am fairly certain that the timing is not off from one box to the next to the point that you are going to notice.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I need some info on 787 timing/cdi
    By mcurcio1989 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 08-09-2010, 10:56 PM
  2. Do I plug the oil holes on the bottom of the OE air box?
    By JMZ400 in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 04-26-2010, 11:47 PM
  3. swaping CDI boxes
    By yama-doo in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 08-31-2007, 05:51 PM
  4. Any tricks on getting out the stock air box?
    By Pale Rider in forum 4-Tec Performance
    Replies: 14
    Last Post: 11-13-2005, 11:59 AM
  5. cargo storage boxes on the front of PWC trailers
    By Compwhiz82 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 06-17-2005, 10:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •