Results 1 to 5 of 5
  1. #1

    Hit 82.6 on my rxpx

    I wanted to thank Erik @ Speedfreeks for getting my ski to break the 80mph barrier.
    We hit 80.4 in the seat and later on in the day hit 82.6 in the superman position. We are currently running the ET 137LE wheel, it generates 14.6 pounds of boost at 8500 RPM. The acceleration is awesome.
    This weekend I ran the ski for about 90 miles and it performed flawlessly.


  2. #2
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,591
    +1
    4,797
    Great speeds, have fun and be careful out there!

  3. #3
    Erik gets results. Hes got me running right at 80mph with a stock ecu (8100) and stock rideplate on a 2Rude wheel. Im debating where to go from here. Erik and I talked about rideplate work.. but im still up in the air about which way to go.

  4. #4
    Chris0060's Avatar
    Join Date
    Sep 2007
    Location
    CT
    Posts
    1,174
    Quote Originally Posted by khaos View Post
    I wanted to thank Erik @ Speedfreeks for getting my ski to break the 80mph barrier.
    We hit 80.4 in the seat and later on in the day hit 82.6 in the superman position. We are currently running the ET 137LE wheel, it generates 14.6 pounds of boost at 8500 RPM. The acceleration is awesome.
    This weekend I ran the ski for about 90 miles and it performed flawlessly.
    Erik is very good. He did some work to my RXP this spring,and I'm going to be consulting him again in the spring... Thanks for the info... MAybe I will be screaming right next to you in the low 80's ...

  5. #5
    SPEED COMES 1/10 @ A TIME SpeedFreeks Racing's Avatar
    Join Date
    Jun 2007
    Location
    BROOKLYN N.Y.
    Posts
    407
    +1
    1

    rxp-x

    bill, i'm glad to hear that your ski is running great and your having fun!!!!

    i think you did about 90miles just in speed runs the day you picked it up....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help! Error code 1661 on my RXPX
    By seadoojosh in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 03-16-2014, 10:46 PM
  2. Is my TDR waterbox fastened properly on my RXPX?
    By tempest.runner in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-27-2012, 06:01 PM
  3. so my venturi/exit nozzle came loose at wot on my rxpx....
    By 98gsxl951 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-19-2011, 04:06 PM
  4. A rock took out my Solas on my RXPX... what should I do?
    By Mikey G. in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-08-2010, 04:27 PM
  5. Replies: 2
    Last Post: 08-25-2008, 04:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •