Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    Rebcammaz's Avatar
    Join Date
    Mar 2009
    Location
    Brick, NJ
    Posts
    95

    Oil Pump Lock-Up?

    Does anyone know what causes the oil pump to lock up? On my 787 with one hour on the rebuilt eng, I noticed an air bubble in the line and it wasn't moving , so i took the pump off and the drive was shattered! But the thing that makes me wonder is the pump was free and still works- I tested it on the bench and it works fine. The drive is not the orig white one that goes inside the crank, it is the black one that goes over the flywheen nut... and it is now in pieces as if the pump locked up for a second. I dont trust the oil pump that is on it now. When I got this ski, it was a basket case and i don't know what caused it to seize up. The original drive looks fine, i have it. I put a used pump on my polaris when the inlet fitting that is pressed into the pump fell out, and that one is fine. What would you do? and I do like the convinence of oil injection... and also i searched through posts before writing this and could not find anything.


  2. #2
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Those drives hardly ever fail. I had a Mikuni oil pump off an old Kawi that had sat in a guy's yard for about 20 years (JK, but it was BAD). That pump was clogged 8 ways to Sunday but the shaft would still turn easy.

    Do you think the drive might have slipped loose and been caught between the crank and the front cover when the cover went on? Was the cover installed with the oil pump on it?

    I know I am seriously paranoid when installing the cover and always take the pump off so I can make sure the drive is on right and then put on the pump.

    Just a thought.

  3. #3
    Rebcammaz's Avatar
    Join Date
    Mar 2009
    Location
    Brick, NJ
    Posts
    95
    I put the cover on first and than the pump on, taking extra care to make sure the drive was in place. I did it all on the bench. I primed the pump with a drill before I put it on...weird huh

  4. #4
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Yeah.

    It sounds like you did it all correctly.

  5. #5
    Rebcammaz's Avatar
    Join Date
    Mar 2009
    Location
    Brick, NJ
    Posts
    95
    what the hell caused that drive to break? Should I reuse that oil pump?

  6. #6
    rob2337's Avatar
    Join Date
    Jun 2007
    Location
    Montréal, Québec Canada
    Posts
    447
    Maybe check to see if the crank is not twisted?? I have seen a 717 engine with a bad flywheel wobble that took out a bunch of things.

    If you have a dial indicator, make sure everything spins true where the oil pump drive engages.


    Just a thought.

  7. #7
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    That is a good idea. That or something came loose?

  8. #8
    Rebcammaz's Avatar
    Join Date
    Mar 2009
    Location
    Brick, NJ
    Posts
    95
    well i got the eng out of the ski now and i and the front spins pretty true by eye. I think i will get another oil pump to be sure this time.

  9. #9
    Rebcammaz's Avatar
    Join Date
    Mar 2009
    Location
    Brick, NJ
    Posts
    95
    Has this ever happened to anyone else?

  10. #10
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    I have heard of them breaking but that was only a couple of times and one guy blamed the drive itself and the other never knew what happened.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Locked Up Pump - Questions
    By rob2337 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-14-2009, 01:25 PM
  2. oil alarm how long do you have before lock up
    By patrick webb in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 07-26-2009, 08:25 PM
  3. Skat Trak Pump Lock up
    By RXPRacer513 in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-10-2009, 06:33 PM
  4. Locking oil pump wide open results!!
    By james k in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 12-26-2007, 07:55 PM
  5. jet pump locked up
    By Mark93spx in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-07-2007, 02:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •