Page 1 of 7 1 2 3 ... LastLast
Results 1 to 10 of 70
  1. #1

    freeflow and topend speed

    I have an 08 gp. Mods are d-plate, intake grate, pump seal kit, and ride plate. This weekend I started to move my battery down, take the bucket out so I am able to see what's happenning underneath. To my supprise I hand no space, there was the sound supresion, long story short I had to put the freeflow and I lost 1.5 mph. What happend? Help please ,what should I do.


  2. #2
    Nothin' runs like a Deere IowanGPR's Avatar
    Join Date
    Sep 2006
    Location
    Waterloo, IA
    Posts
    1,608
    this is typical, you're losing rpm's with the change. find a mod to counter that change and bring your rpm's back up.

  3. #3
    What other mods , I am trying to keep it simple cause I don't have the reinforcement, afraid it will crack if I get to much speed. It was at 70.5 now cause of the freeflow 69. I hear they start craking at 72

  4. #4
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,495
    +1
    618

    ff

    i lost some top speed also(63.5) BUT DON'T SHE SOUND NASTY! your going to need it if you add a holeshot kit.

  5. #5
    Sounds great I love it. But you can't afford to lose mph . When your only at 70. Does this mean that everyone with the ff is losing 1.5mph. Why keep it ?

  6. #6
    mjh3ides's Avatar
    Join Date
    Jul 2007
    Location
    Jupiter, Florida
    Posts
    6,799
    +1
    2,013
    Quote Originally Posted by GPR View Post
    What other mods , I am trying to keep it simple cause I don't have the reinforcement, afraid it will crack if I get to much speed. It was at 70.5 now cause of the freeflow 69. I hear they start craking at 72
    I would definately reinforce the tunnel. They're more likely to fail on more heavily modded boats, but I've heard of them cracking on stock boats too. A power/race filter is a simple bolt on that will help you get the revs back up.

  7. #7
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,155
    +1
    44
    Have you compensated with the fuel controller?

  8. #8
    No efi, only the mods that are listed. Its not bogging out that's why I haven't put it on. It has no air filter either, thanx for the comments , should I keep it on?

  9. #9
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Honestly 'GPR' .....do the tunnel reinforcment! Bad things happen when the tunnel cracks and the shoe drops. And yes, they can crack at 68-72 mph. Do yourself a HUGE favor..

  10. #10
    Should I leave it on or just take it off ? (The ff)

Page 1 of 7 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. high and low speed screw settings?
    By johnson7454 in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 05-21-2008, 07:08 AM
  2. Initial carb tuning... and low speed adjusters
    By pdxrealtor in forum Sea Doo Classifieds
    Replies: 14
    Last Post: 04-29-2008, 08:05 AM
  3. Cool Air and Water = Speed
    By motorsport17 in forum 4-Tec Performance
    Replies: 0
    Last Post: 09-08-2007, 05:25 PM
  4. Water routing and rpms/speed
    By Vern in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-18-2007, 04:50 PM
  5. Weight Distribution and MORE speed
    By sr71bb in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-30-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •