Results 1 to 5 of 5
  1. #1

    Engine Runs Great.....But

    So I got the mods all complete on the bosses 04 RXP (Thanx to all for their help). Rebuilt supercharger, water box mod, McMaster Carr Bellville's, new wear ring and a Solas 13/18. Boss says the engines runs very smooth

    But it seems as though it has been DETUNED! 7200 rpm tops and only 62 mph on the guage.

    Any ideas?

  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    venice fl.
    I see you did the charger. What is the slip set at? Also you may want to check out this thread.

    Your rpms are a little lower than the usual symptoms but its worth looking into.

  3. #3
    I had read that post before. This boat has not been to the dealer. Don't know if it has the harness or not. I'll look into that when it come back from the lake.

    Slip on the SC was 155 when I put it in. (yesterday) Lake is smooth as GLASS!!

  4. #4
    richrxp's Avatar
    Join Date
    Jun 2006
    Did you check your hoses?

    Might have a boostleak somewhere.

    Maybe a hose came off,just to be sure check your hoses.

    The 13/18 seems to be the right impeller for your setup,its for a stock rxp.

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Morgan City, LA
    04 RXP + 7200 rpm = possible knock sensor update botch job

    Check to see if the knock sensor update harness is plugged in. You will find it between the stock wire harness and knock sensor connector. It's about 8" long.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	knock sensor update.jpg 
Views:	44 
Size:	78.9 KB 
ID:	152754  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 49
    Last Post: 11-25-2008, 08:20 AM
  2. Mine runs great!
    By SeaDoocer in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 08-11-2007, 08:49 PM
  3. First Runs
    By TxPro1200 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-12-2007, 02:50 PM
  4. Great Pictures,Great day
    By Alex13 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 08-09-2006, 08:17 PM
  5. Great site with Great people
    By wavehummer in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 07-05-2006, 05:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts