Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32
  1. #1

    Join Date
    Dec 2007
    Location
    Flower Mound, TX
    Posts
    63

    Finally blew it up

    Well my 2004 RXp finally blew up!!! Looks like the #2 piston is half gone...Well I have a good winter project now. Going to do a total rebuild on it now. Going to add some chines to the hull and see if i can make this thing turn like i want it to...also thinking about a big bore?? Going to start pulling all apart soon....This is going to be a lot of fun...


  2. #2
    Half gone as in melted, or made contact with the valves?

  3. #3

    Join Date
    Dec 2007
    Location
    Flower Mound, TX
    Posts
    63
    Im about 95% sure i melted it. Trying to clear an area on my bench to put the motor on. Got a late season rush on 4 stroke motors. Have 4 apart now. Im trying to find old post on hull mods and i cant find any...kinda want to know what people have tried. I have a Kawasaki stxr hull that im looking at...was thinking about trying something like that

  4. #4
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    How many hours? Sounds like you were expecting it to blow.

  5. #5
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    or either pushing it into blowing it

  6. #6

    Join Date
    Dec 2007
    Location
    Flower Mound, TX
    Posts
    63
    Maybe 10 since the last rebuild. I was not expecting to blow. I had planned on a rebuild this winter. I was running at 8550rpm...it was running great when it happened. I had av gas (100+ low lead). Thinking mabe need to be running 110. Sad thing is i had a drum of it at the shop. New blower worked great. Wish it had stayed together so i could have tested some hull mods first.

  7. #7

    Join Date
    Dec 2007
    Location
    Flower Mound, TX
    Posts
    63
    oh i was pushing it....but it has been pushed harder in races...a lot harder...just think it might have just been time.

  8. #8

    Join Date
    Dec 2007
    Location
    Flower Mound, TX
    Posts
    63
    well it was not a piston or valve...looks like a rod or the crank is gone...

  9. #9
    Spin a bearing?

  10. #10

    Join Date
    Dec 2007
    Location
    Flower Mound, TX
    Posts
    63
    im pulling the motor now, was very happy it did not get the head. kinda feels like a lower bearing on the center rod. it was a good knock when it went.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. OK guys! Im finally doing it!!!!! PICS UP
    By WATER WOODY in forum Yamaha Open Discussion
    Replies: 57
    Last Post: 06-22-2009, 11:57 PM
  2. I Finally Make IT! 80 MPH
    By suck my wake in forum 4-Tec Performance
    Replies: 27
    Last Post: 07-23-2006, 10:06 PM
  3. My Engine is Ruined by Dealer & BRP covers it up w/ BS
    By Tom Clarke in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 04-26-2006, 07:45 PM
  4. HA! HA! Went and tore it up today. mid 70's and sunny.
    By Water4fire in forum 4-Tec Performance
    Replies: 34
    Last Post: 01-01-2006, 09:23 AM
  5. Hello All, I finally made it...
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 10-31-2005, 07:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •