Results 1 to 3 of 3
  1. #1
    canadian iceman
    Join Date
    Dec 2007
    Location
    medicine hat, alberta, canada
    Posts
    627
    +1
    22

    question on installing ti retainers

    ok so i have installed the les cooke retainers in my rxpx and when i was ready to install rocker arm shaft i couldnt get it to seat totally on the head.?? The instructions i had was from the riva spring and retainer upgrade kit and it says nothing about where the crank/cam position should be...yet the manual says that the 3 cylinder has to be at top dead centre??... i finally just installed the dam shaft and tightend down the bolts with the extra 90 degree stretch(i used new bolts)....anybody comment on this....is this going to work ok??


  2. #2
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    The engine should be at TDC to reinstall the rocker shaft. You either need to keep bumping the engine without the plugs in to get it or take the pump cone off and turn it by hand. I would think you could damage something just trying to put the rocker shaft back on without it being at TDC.

  3. #3
    canadian iceman
    Join Date
    Dec 2007
    Location
    medicine hat, alberta, canada
    Posts
    627
    +1
    22
    went back to verify if i was at top dead centre on front cylinder and ....i was!! the cam marks are in perfect alignment so i am 100% good on this...i must say....those stretch bolts....WOW.... do you crank on those baby's...i thought i was going to break them for sure!! crazy shit man!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question on installing Blow Off Valve
    By frogurt in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 06-26-2011, 10:56 PM
  2. question on 787 motor install shiming/align.!!!!!
    By flyby9er in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-18-2007, 12:50 AM
  3. Replies: 3
    Last Post: 04-09-2007, 10:33 PM
  4. Questions On Riva Grate Install
    By Flynfox in forum 4-Tec Performance
    Replies: 12
    Last Post: 03-29-2007, 11:54 AM
  5. Question on Riva Sponsons install...just wondering?
    By carbuff91 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-14-2006, 03:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •