Results 1 to 4 of 4
  1. #1
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123

    fuel baffle issues

    I've read throughly the threads regarding the fuel baffle problems and so forth, here's the deal. I have 3 skis, 97gtx 96gsx 00xp, ok gsx works perfectly fine. so i wanted to test the fuel baffles of my other 2 skis, i hooked them up to my gsx, i put the key in, and its just a blank reading.
    i did the same thing with 3 different fuel baffles and same thing, then i hook the gsx fuel baffle back in (its inside the tank.) and it works fine,
    this is driving me crazy!!!!
    do i have to disconnect the battery after hooking up different baffles so it can reset?


  2. #2
    When you did this test, was the baffel in the tank or just plugged in? If just plugged in, was it upside down (indicating full fuel)? If you've ever had your skis that low on fuel it will read blank bars. When you plugged the key in, did it flash 8 full bars across the gauge? Thats telling you its checking the system.

  3. #3
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Go to the parts finder to the left, and click on each year to see if the 96&97 are the same part number. If they aren't, they aren't compatible. I know for sure the 2000 isn't. I can't believe you assumed the resistance readings from all the years would be the same. Do the fuse trick stickied at the top for the 2000 pickup...that's all that is wrong with it.

    Just a FYI...if you disconnect the pickup and the gauge goes full up upon power up, it is the pickup. No movement from the gauge when energizing, it's the gauge.

  4. #4
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    i think 96XPSS is right that was one of my thoughts too.
    when i hooked the baffles. i moved the magnet in halfway. not in the top and not in the bottom, when i hook up the key, its just blank, no flashing no nothing, but once i hook up the original baffle it works perfect. so it just has to be compability.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel Baffle Sending Unit Repair !
    By RX951 in forum 2-Stroke Performance
    Replies: 128
    Last Post: 09-11-2016, 07:15 AM
  2. Fuel Baffle Sending Unit Repair !
    By RX951 in forum Sea Doo How To & FAQs
    Replies: 20
    Last Post: 09-07-2012, 07:05 PM
  3. Fuel baffle issue (baffling me)
    By ubernoob in forum 2-Stroke Performance
    Replies: 4
    Last Post: 05-03-2011, 04:15 PM
  4. Ultra LX / 250X Fuel System Issue, I need ideas
    By bluebalz in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-12-2007, 12:17 AM
  5. Fuel Injector issue..
    By Brueskerxp06 in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-03-2007, 09:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •