Results 1 to 3 of 3
  1. #1

    Fuel gauge problem?

    I have 2 kawasakis" 2007 stx f 1500/1200 both have been sitting for 3- months .I would start them every 2 weeks and run them ,any how can fuel with the darn 10% ethanol screw up the fuel gauge sending units? My 1200 has a full tank and the warning for low fuel keeps coming on. So I checked my 1500 ski and the gauge was fine, I swapped out sending units to see if the 1200 would keep giving me the same problem quess what? It did so I figure my problem is elsewhere maybe with a plug or a wire .So I put my 1500 fuel gauge sender back in the 1500 and quess what ? now the 1500 saki is doing the same thing ,does any one think the ethanol additive sitting and absorbing moisture could have done this ? I noticed the fuel has turned a little reddish color but that maybe from the fuel stabalizer i added. Also I am going to siphon and clean the tanks and fill up with hi test marine grade to see if that helps the sending units .Any ones opinion would be greatly appreciated. Thanks

  2. #2
    I have a zxi, so I am not sure if it is the same system, but the old kawi's were know to have the float get stuck, or come apart from the sensor. I will have to look you boat to to see if its the same as mine...

  3. #3
    I just found out my fuel level sensors shorted out in both skis .It seems kawi has had some issues with them ,due to moisture build up in the tanks .The ethanol they are putting in the fuel causes condensation in the tank more than normal fuel does. And that is what the dealer at kawi had mentioned he has seen a lot of them over this past summer. I drained my tanks and ordered 2 new fuel level sensors .Looks like just pure marine fuel and sunoco 114 for me for now on.........learn as we live ......

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gas gauge problem!
    By dcs191919 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 09-05-2007, 07:45 AM
  2. fuel gauge
    By Blackhardt in forum 2-Stroke Performance
    Replies: 3
    Last Post: 05-03-2007, 06:31 PM
  3. Fuel gauge not working?
    By mboley in forum Polaris Open Discussion
    Replies: 10
    Last Post: 04-25-2007, 09:23 PM
  4. Weird Gauge Problem
    By '02GPRider in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-09-2007, 11:38 AM
  5. New Fuel Gauge
    By 1FastTrespiper in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-03-2005, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts