Results 1 to 6 of 6
  1. #1
    Tom Clarke's Avatar
    Join Date
    May 2005
    Location
    Surf City, California
    Posts
    274

    Warning about ERZPerformance........

    I bought a "Walbro GSS342" from this company and was assured that is WAS a GENUINE Walbro only to have it fail after only 4 hours. I contacted ERZPerformance after the fuel pump failure and they informed me that there is NO WARRANTY on their products. It seems obvious to me that they are selling a Chinese knockoff of the Walbro products. I installed the fuel pump right before the S F Bay race in late June and it failed during the Pittsburg race in mid-September. Had to re-install my stock SeaDoo fuel pump before the S D Races 2 weeks ago just to get the ski to run. ERZPerformance is a complete RIP-OFF. Would love to be able to get my hands on the POS owner of this company for a little payback.
    T C


  2. #2
    richrxp's Avatar
    Join Date
    Jun 2006
    Location
    Netherlands
    Posts
    949
    +1
    1
    Did you pay the same price as a genuine walbro?

    No guarantee is not good,what a bad way to do business,can't you do anything about it?

    There is a law for internet buys,and what they did isn't ok!

  3. #3
    Tom Clarke's Avatar
    Join Date
    May 2005
    Location
    Surf City, California
    Posts
    274
    Paid $100, was told before I bought it that it was genuine Walbro. Can't do anything except post the truth about the POS company. Hopefully karma will catch up to them.
    T C

  4. #4
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    What happened when it failed? symptoms it had? Did it just die?

    I bought mine from them a few months ago as well. I hope it dosen't do the same thing too

  5. #5
    Tom Clarke's Avatar
    Join Date
    May 2005
    Location
    Surf City, California
    Posts
    274
    I was in the back straight of the Pittsburg, Ca race where it was quite rough and and came down hard after a swell and the enginge just died, as if I had pulled the lanyard. I forget the code that came up on the self diagnostic but it was the one that said something to the efffect of bad fuel pump or connection. I put the stock fuel pump back in the following week and it solved that problem.
    T C

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Sorry to hear that happened to you Tom.

    If you want a genuine Walbro you can get them from Summit Racing
    http://www.summitracing.com/parts/VPN-GSS342/

    They are on sale right now for $79.95

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Warning about R&D intake grate.
    By FIRE0021 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 61
    Last Post: 04-21-2013, 07:47 AM
  2. couple gp800r ques about warning and temp sensor need help
    By silvercrxsir in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 08-12-2012, 01:24 PM
  3. a warning about reverse!
    By jk111 in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-08-2012, 02:25 PM
  4. about my yamaha gp760?? why does the warning come out and say 000 trip pls help!
    By RICHARDHX in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-11-2011, 08:36 AM
  5. Question about beep? Warning? Help
    By scottie mac in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-07-2010, 09:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •