Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    fh23rxp-x's Avatar
    Join Date
    May 2008
    Location
    Miami
    Posts
    462

    rxp-x misfire at WOT

    i am having some issues with my x , its been suttering and misfiring on iddle and at wot . i change the spark plugs and nothing, the same . I've checked all the coils and the look fine and are throwing spark .... i am very frustrated since the fact that is not working properly.. some guy told me to check my my crankshaft position sensor ... i have 73 hours on my sky .
    can somebody help me


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by fh23rxp-x View Post
    i am having some issues with my x , its been suttering and misfiring on iddle and at wot . i change the spark plugs and nothing, the same . I've checked all the coils and the look fine and are throwing spark .... i am very frustrated since the fact that is not working properly.. some guy told me to check my my crankshaft position sensor ... i have 73 hours on my sky .
    can somebody help me
    IC may be leaking. You should pressure test it.

  3. #3
    fh23rxp-x's Avatar
    Join Date
    May 2008
    Location
    Miami
    Posts
    462
    how can i do that

  4. #4
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by fh23rxp-x View Post
    how can i do that
    The easiest way is to remove it from the boat, plug the water exit line and bleed line, then connect a garden hose to the water inlet so that there is no leak, turn the hose on and see if any water begins to drip from the air passage.

  5. #5
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Have you checked your SCer? What kind of rpms at WOT are you getting? I would check the I/C too like Speedskixp said. Its not that hard to pull. I guess you are out of warranty? Ever have a SCer failure on this ski?

  6. #6
    fh23rxp-x's Avatar
    Join Date
    May 2008
    Location
    Miami
    Posts
    462
    Quote Originally Posted by jp1300r View Post
    Have you checked your SCer? What kind of rpms at WOT are you getting? I would check the I/C too like Speedskixp said. Its not that hard to pull. I guess you are out of warranty? Ever have a SCer failure on this ski?



    i just pulled out my i/c and and nothing its good . i've never had a supercharger failure . i am still under warranty , but i am have a hard time dealing with them . last time i took the ski they charge 95 bucks just to tell me my spark plugs were bad . thats what they call diagnostic

  7. #7
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Ot could be a bad fuel injector or maybe water trapped in the fuel rail.

  8. #8
    2008 RXP-X
    Join Date
    Mar 2008
    Location
    Carrollton, TX
    Posts
    125
    I bet you have a dirty/clogged fuel injector.

  9. #9
    how do the boots on your coils look I know of a few skis now if these swell they cause the coils to be loose and moisture gets in there...get some water dispersent spray and spray your coils see if there is any gap were the rubber boot seals onto the engine cover

  10. #10
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by Pooche View Post
    how do the boots on your coils look I know of a few skis now if these swell they cause the coils to be loose and moisture gets in there...get some water dispersent spray and spray your coils see if there is any gap were the rubber boot seals onto the engine cover
    +1 definitely inspect the coils also.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 rxp surging at wot loading up in mid and throttle stabs
    By turbojamie in forum 4-Tec Performance
    Replies: 18
    Last Post: 06-21-2013, 06:45 PM
  2. seadoo rxp max out at 6500 rpm with WOT
    By rxpsquad in forum 4-Tec Performance
    Replies: 21
    Last Post: 03-20-2012, 10:21 AM
  3. Replies: 5
    Last Post: 08-22-2010, 09:27 AM
  4. Remanufactured motor ran at WOT without Break in.
    By ccassone in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 03-19-2006, 08:35 AM
  5. RXP FIBERGLASS CRACKED AT STRAKES
    By jawz in forum 4-Tec Performance
    Replies: 4
    Last Post: 02-28-2006, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •