Results 1 to 7 of 7
  1. #1

    Join Date
    Sep 2007
    Location
    Philadelphia, Pennsylvania, United States
    Posts
    251

    Assistance needed with Flywheel/Pickup please.

    Well, In the process of the 1200 to 1300 efi conversion build I am having a small problem. I installed the Flywheel and Stator/cover yesterday and it went on with no problems, but I notice now that when I rotate the motor by hand I can hear, and slightly feel, a "CLICK" when the 3 magnets on the outside of the flywheel pass by the pickups on the stator cover. Is this normal? It doesn't really stop the crank from turning, but I am still concerned. Anyone have any ideas? The flywheel is on correctly (i think) and the bolt was torqued to 53ft lbs as per the manual.


  2. #2
    He's using a 07 13r flywheel along with the stator and cover out of the same boat.

  3. #3
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,156
    +1
    44
    That's normal.

  4. #4

    Join Date
    Sep 2007
    Location
    Philadelphia, Pennsylvania, United States
    Posts
    251
    Thanks for the Info on that. Should there be any kind of resistance when I hear the click. It's not like it stops the crank from turning, but it diefinatly is noticeable.

  5. #5
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    the magnet is inside the flywheel, and may cause some very slight resistance when turning by hand

  6. #6

    Join Date
    Sep 2007
    Location
    Philadelphia, Pennsylvania, United States
    Posts
    251
    Thank you both for the help. Now I can rest a little easier knowing that it is normal. Cant wait to drop the motor in on Wed!

  7. #7

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    IMO you should pull the stator cover back off and check and make sure the washers for the starter spring didn't come out and stuck to the flywheel. You should not hear a click. Also make sure the keyway didn't slip out when you install the flywheel and hiting the case as it turns. Better safe then sorry.
    Mike

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with stx pump please
    By ALM MOTOR SPORTS in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 09-14-2009, 11:44 AM
  2. Need help with slh 700 please!!!
    By nick34 in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-09-2009, 12:56 PM
  3. Assistance needed with educational material
    By shawn alladio in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 12-29-2007, 02:46 PM
  4. Major Assistance needed with STX-15F
    By 785xp in forum Kawasaki PWC Performance (4-stroke)
    Replies: 17
    Last Post: 09-15-2007, 05:57 PM
  5. HELP NEEDED ASAP!! need part numbers from those with service manuals please
    By cue03 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 03-17-2007, 05:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •