Results 1 to 10 of 10
  1. #1
    bullisland's Avatar
    Join Date
    Jul 2009
    Location
    757 Virginia
    Posts
    137

    URGENT! Disconnecting stator wires???

    I'm in the process of pulling the engine and can't figure out how to disconnect the wires from the stator...would think that there should be a quick disconnect somewhere in there but theres not??? How do I manage those wires to get the engine out??

    If nothing else...can I cut the wires and put it in quick disconnect where I cut them??? Know how to do that, just don't know if you can just do that for any electrical wires or what...

    Thanks! Trying to knock this out within the next couple hours so any quick help would be greatly appreciated!


  2. #2
    Flying Scotsman's Avatar
    Join Date
    May 2006
    Location
    IllINOIS
    Posts
    6,514
    +1
    4
    Open up the e,box and disconect them.

  3. #3
    SKEricsson's Avatar
    Join Date
    Jul 2009
    Location
    Washington State
    Posts
    22
    As The Great Scot says, pull the cover on the ebox. There are quick connectors inside that disconnect the stator wires, then a couple of nuts for the grounds. There are two green wires also that are separate from the connectors, mark them so you know which is which, but I don't think it matters but better safe than sorry!

    There are no connectors exposed where water can get into them and corrode them.

  4. #4
    bullisland's Avatar
    Join Date
    Jul 2009
    Location
    757 Virginia
    Posts
    137
    I've gotten there but how on earth do I get the disconnect to pull out of the electrical box? Mine are run through that water tight rubber. I've gotten both of them disconnected, but now just sitting there looking at two disconnects haha. Brains fried and nothings making sense to me anymore haha

  5. #5
    Napkins........ I Fly a Starship seajm's Avatar
    Join Date
    Oct 2007
    Location
    W. Palm Beach
    Posts
    100
    Just take the ebox out with the motor, three bolts from the back. Lay the ebox on top of the motor then lift it all out!

  6. #6
    Flying Scotsman's Avatar
    Join Date
    May 2006
    Location
    IllINOIS
    Posts
    6,514
    +1
    4
    The rubber slides out of the box the plugs unplug and the grounds are 10 mm heads easy enough.
    Or leave the stator and front cover in the ski just remove the 8 12 mm bolts and pull of the front cover.

  7. #7
    Here come the smokers! OBXJeepGuy's Avatar
    Join Date
    Aug 2008
    Location
    Outer Banks, NC
    Posts
    1,393
    Or do like I did: Get pissed off, cut the wires, and use a Deutsch connector to put it back together!

  8. #8
    bullisland's Avatar
    Join Date
    Jul 2009
    Location
    757 Virginia
    Posts
    137
    Quote Originally Posted by Flying Scotsman View Post
    The rubber slides out of the box the plugs unplug and the grounds are 10 mm heads easy enough.
    Or leave the stator and front cover in the ski just remove the 8 12 mm bolts and pull of the front cover.
    just finished it! I was out there getting mad and messing with the rubber gasket, and was like...WAIT A SECOND!!! haha...and they just slid right out!

    Thanks for the help fellas! Engine is out and ready to start the inspection/rebuild!

  9. #9
    SKEricsson's Avatar
    Join Date
    Jul 2009
    Location
    Washington State
    Posts
    22
    Isn't it amazing how the most complicated looking things can turn out to be so simple? Nice, let us know what you find!

  10. #10
    bullisland's Avatar
    Join Date
    Jul 2009
    Location
    757 Virginia
    Posts
    137
    haha yes...VERY simple! I was just pushed for time and rushing myself and overlooked it easily.

    what I found was what I expected...I have a rebuild thread going with some pictures.
    http://greenhulk.net/forums/showthread.php?t=108547

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 SL 750 - burned stator wires
    By Tystarr8 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 04-03-2013, 07:36 AM
  2. Bolts to stator wire loom gromet, inside of cover right ?
    By 153stars in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-23-2011, 07:22 PM
  3. WTB Polaris Stator Wire Clamp
    By CrazyA in forum Polaris Classifieds
    Replies: 12
    Last Post: 07-22-2011, 05:14 PM
  4. Missing thermostat & light Blue wire disconnected & ground wire
    By sebas54 in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 05-09-2010, 12:47 PM
  5. burned up the stator wiring all the way to the box/ouch.
    By bowsniper in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-17-2009, 09:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •