Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1

    Just picked up a 96 gsx and have a few questions....

    I recently found a good deal on a 96 gsx but it needs some work. The engine and carbs were just rebuilt last year. The weird thing is though, the owner explained that the ski sometimes will hesitate to take off. When you first get it out on the lake it will take off and run all out with no problem. However, afters it been ran for a while it will hesitate to take off, and then just shoot off. If anyone has any ideas as to what might cause this i would appreciate any tips. The other question is that part of the display is really dim because the backlight went out on it. How hard are these to change?

    Thanks for your time,


  2. #2
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    check your carb filters and the main big filter under the steering colummn, even after a carburetor rebuilt if the tank was not cleaned out and the engine was ranned on empty/reserve it would have sucked up all the trash out, your problem sounds like fuel delivery problems, get this checked out, if not that brand new engine will seaze due to running lean.

  3. #3
    If it was fuel delivery problems wouldn't it affect it at all times instead of just take off? sorry if this is completly wrong just trying to understand how this all works.

  4. #4
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    ok then wht do YOU believe it is?
    you need 3 things to make an engine run,
    fuel, compression, spark.
    i still believe its something to do with your carbs, maybe the lows and highs are not set right,

  5. #5
    steach's Avatar
    Join Date
    Dec 2005
    Location
    Rock Tavern, NY
    Posts
    3,174
    +1
    174
    After you verify that the fuel system is clean run a test on the voltage rectifier.

    When symtoms begin unplug the red wire and see if it fixes the issue.

  6. #6
    Deanrw3's Avatar
    Join Date
    Oct 2008
    Location
    west MI
    Posts
    249
    What do you mean by hesitate? Does it bog or does it almost shut down?

    The low speed screws could be set wrong, to rich if it boggs or too lean if it drops off. Maybe they got set wrong on the rebuild. How many turns are they at now?

    dean

  7. #7

    questions on carbs

    Look at the plugs this will give an idea of carb settings, black fould plugs are a rich running condition or excessive oil burning condition, white plugs are a lean running condition [ this is very bad ]. You are looking for a gray even buring condition on the plugs, I would tend to agree that mixture screws are adjusted wrong, this would explain why the engine is cold or warm the symptoms change

  8. #8
    JKR1300's Avatar
    Join Date
    Jan 2006
    Location
    St Louis & 6mm LotO
    Posts
    497
    +1
    6
    Try cleaning the power valves (or whatever they're called on a Doo)
    They're vaccum operated and will stick when gummed up with carbon

  9. #9
    thanks a lot for all the tips! i greatly appreciate it! what i mean by hesitate is that the rpms go up but the ski just sits in the water and barely goes but after a short amount of time the thing just kicks in out of nowhere and it will just launch off and run fine. As for the carb settings i will make sure i post it later today. I actually get the ski dropped off to me tonight.

  10. #10
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    Quote Originally Posted by MSCARD02 View Post
    thanks a lot for all the tips! i greatly appreciate it! what i mean by hesitate is that the rpms go up but the ski just sits in the water and barely goes but after a short amount of time the thing just kicks in out of nowhere and it will just launch off and run fine. As for the carb settings i will make sure i post it later today. I actually get the ski dropped off to me tonight.
    sounds like cavitation, check you wear ring and carbon seal, make sure you are not getting an air leak into the pump from the carbon seal, and also be careful cleaning the RAVE valves dont let the springs pop out when you take out the black cap. and just clean the guillotines(blade looking things with a wire brush,) do one by one so you can know how they go back in, cause if you install them upside down, they will not open during high revs

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Just picked up a 97 gsx..
    By Paresmotorsports in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-04-2013, 11:45 AM
  2. Ok, I just pulled my SC and have a few questions
    By lt1pwr in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-29-2012, 02:37 PM
  3. just picked up a 96 SL700, how to get rid of mice
    By turk0004 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 10-19-2009, 02:33 PM
  4. I just picked up a 96 Hurricane. Newb advice needed...
    By rnewman36 in forum Polaris Open Discussion
    Replies: 20
    Last Post: 08-31-2009, 06:59 PM
  5. Just picked up a 96 seadoo challanger. need some help
    By ADAMBOMB in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 10-22-2008, 10:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •