Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 60
  1. #1
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577

    Riva PowerCooler Results (Discussion and tips)

    I finally grabbed the ski and ran to the lake today.
    Air temp around 64*F not sure what the water was.

    Water conditions were fairly ruff. Not calm water at all due to winds.

    Was on a 82mm nozzle ring.
    80.4 mph was the best of 2 good runs at ~8,400rpm.
    I was running at Lambda .90-.93 which is leaner than I had been running at about .85 Lambda

    I also had a few times where at WOT it cut out for a second. That is why I only made the 2 runs. Lack of Fuel???


    The first half or so of the log is without the new I/C...
    Added log file


  2. #2
    desperado's Avatar
    Join Date
    Aug 2007
    Location
    Montreal, Canada
    Posts
    453
    +1
    3
    ......
    Last edited by desperado; 10-16-2009 at 09:13 PM.

  3. #3
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    I think def. fuel or lack of enough of it... I added the log file to the original post.

  4. #4
    Addicted Member 5001craig's Avatar
    Join Date
    Jul 2007
    Location
    Northeast Indiana
    Posts
    2,924
    +1
    11
    Did you run the same tune as you were running prior to installing the new IC?

  5. #5
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Quote Originally Posted by 5001craig View Post
    Did you run the same tune as you were running prior to installing the new IC?

    Yes, that was the first time on the water with the I/C.
    I needed to test after just the new I/C so I had only changed one thing.

    I have another file and new injectors to try out now.

  6. #6
    desperado's Avatar
    Join Date
    Aug 2007
    Location
    Montreal, Canada
    Posts
    453
    +1
    3
    .....
    Last edited by desperado; 10-16-2009 at 09:13 PM.

  7. #7
    It's not the destination, it's the journey!! Rip'nTear SHO's Avatar
    Join Date
    Apr 2008
    Location
    Ft. Lauderdale
    Posts
    4,573
    I have to admit.....I had a certain amount of apprehension and trepidation making a purchase of this amount.....but now that I've seen the quality of this piece and felt the weight/sturdiness of it.......I'm very glad that i made the purchase. The mounting system is beautiful and should more than compensate/tolerate what i'll throw at it offSHOre.

    Quality and design of this intercooler is unmatched, it's almost too sweet to mount in the ski.....maybe i'll put it in a glass case and just stare at it....

    A big salute to Bruce and Riva for putting out such a quality piece for the SHO/FZR.....
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC00894.JPG 
Views:	185 
Size:	2.83 MB 
ID:	155042   Click image for larger version. 

Name:	DSC00895.JPG 
Views:	161 
Size:	3.04 MB 
ID:	155043   Click image for larger version. 

Name:	DSC00897.JPG 
Views:	128 
Size:	3.08 MB 
ID:	155044  

  8. #8
    Addicted Member 5001craig's Avatar
    Join Date
    Jul 2007
    Location
    Northeast Indiana
    Posts
    2,924
    +1
    11
    Quote Originally Posted by Rip'nTear SHO View Post
    .....maybe i'll put it in a glass case and just stare at it....
    OR......you could buy that second one and let me see it for a couple years...

  9. #9

    Join Date
    Sep 2008
    Location
    NE Ohio
    Posts
    306
    Quote Originally Posted by SHOBiz View Post
    I finally grabbed the ski and ran to the lake today.
    Air temp around 64*F not sure what the water was.

    Water conditions were fairly ruff. Not calm water at all due to winds.

    Was on a 82mm nozzle ring.
    80.4 mph was the best of 2 good runs at ~8,400rpm.
    I was running at Lambda .90-.93 which is leaner than I had been running at about .85 Lambda

    I also had a few times where at WOT it cut out for a second. That is why I only made the 2 runs. Lack of Fuel???


    The first half or so of the log is without the new I/C...
    Added log file
    What program is used to read your log file?

  10. #10
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Quote Originally Posted by Jack B View Post
    What program is used to read your log file?

    MoTec i2

    www.motec.com

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SOLD Sold Riva through hull pipe and Exhaust tip Sold
    By Taylor215 in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 10-03-2013, 07:30 AM
  2. WTB: Riva (or similar) Rear Exhaust Tip and 2 Couplers
    By thompsdw in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 03-29-2009, 02:50 PM
  3. riva power filter install and grate question
    By CarFanatic in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-28-2006, 12:32 PM
  4. Riva Wedge Results Good and Bad
    By excess in forum 4-Tec Performance
    Replies: 16
    Last Post: 06-19-2006, 09:22 PM
  5. Riva Pricing on RXP and RXT
    By jack in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 06-24-2005, 03:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •