Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    V-force just installed

    i didn't feel any mid-range power added after the installation.

    i have a full stage 2 kit on my 2008, 1300 GPR.

    same top speed on the GPS i get 68 - 69.

    i feel that there is a chip to something holding the ski from reving above 7 k.

    any one have v force can tell how much top speed gained.

    thanks


  2. #2
    They should improve your low and mid range more so than the top end speed.

  3. #3
    zx11rider's Avatar
    Join Date
    Jun 2009
    Location
    Cape Coral
    Posts
    1,132
    Did your rpms go up what were they before and what are they now the vf3's add rpms more rpms usually means more speed, what prop do you have maybe it is to big for your motor to turn. Ron

  4. #4
    my rpm was 6940-6980. occasionally turns to 7010.

    now i can see 7020-7080 consistence.

    im running DF 14/20.

    i know that should mean more speed, but i got 68 almost every time on the gps before, now 67 is ok , but 68 difficult.

    something does not seems to be logic. maybe i have to check for loose bolts for ride plate so it is adding more drag force.

  5. #5
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    you have too much prop....your close to deto and wont yelid good speeds as well as ruin your engine,the best range to sit in is 7150-7250

    most say deto will hurt your engine around the 7k mark i found deto damage at 7080 with my jump ski it had started eating #3 pistion so i dropped a degree

    rough guide is you drop 1 degree on the rear of prop you can gain 50-70 rpm,if you are not adding more mods i would drop her to 13/19

  6. #6
    Moderated
    Join Date
    Oct 2006
    Posts
    3,711
    full stage 2 should be faster than that, are you sure its not dragging under the hull somewhere?

  7. #7
    also do you have a milled or aftermarket head? the higher compression would allow you to spin that 14\20.
    also how hot is it in your area? temps effect rpm`s...
    IMHO:
    I see anywhere from 7050-7180-90, with an occasional 7200+ when using the VF3`s.
    absolutely a difference, better acceleration, quicker response, more stable fuel delivery at upper rpms compared to the OEM.

    the VF3`s have more pedals/larger area for more air/fuel mixture to enter the case. The CF reeds won`t flutter under high rpms.

    with the package that you have on your GPR, you should be accelerating very quickly, mid range should be snappy and very crisp. it should also pull like a train if the efi controller is adjusted properly...

  8. #8
    Updates::


    yesterday i run 7070-7090 all the time. with 67-68 on the GPS.

    i took the ski out of the water and i called the day off, then i look at the prop, and i found a rope around the shaft and some plastic bags. i clean it and test the ski again,

    amazingly it pulled as it should, and was a noticable diffirence also i got 70.0 MPH. on the GPS, but im not sure how much rpm, as my meter become crazy sometimes, i dont know why, underfull throtle it reads 8k -9k.
    i dont know why, but finaly i got my 70, now i think i can make 68-69 every run, and 70 with smoth water.

    i have to figure some way to keep the rpm meter gives a relaialbe reading every time.

    i think a 72 mph is what i should get, so im not far behind.

    i have jim ride plate. and Riva heads. my efi setting 6-1-7-6.

  9. #9
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,139
    +1
    1,050
    Quote Originally Posted by vette96 View Post
    i have to figure some way to keep the rpm meter gives a relaialbe reading every time.
    Which one are you using?

  10. #10
    Quote Originally Posted by vette96 View Post
    Updates::


    yesterday i run 7070-7090 all the time. with 67-68 on the GPS.

    i took the ski out of the water and i called the day off, then i look at the prop, and i found a rope around the shaft and some plastic bags. i clean it and test the ski again,

    amazingly it pulled as it should, and was a noticable diffirence also i got 70.0 MPH. on the GPS, but im not sure how much rpm, as my meter become crazy sometimes, i dont know why, underfull throtle it reads 8k -9k.
    i dont know why, but finaly i got my 70, now i think i can make 68-69 every run, and 70 with smoth water.

    i have to figure some way to keep the rpm meter gives a relaialbe reading every time.

    i think a 72 mph is what i should get, so im not far behind.

    i have jim ride plate. and Riva heads. my efi setting 6-1-7-6.
    6 1 7 6 ???, the number 2 pot is to low... bring it up to 5 and test from there...the number 3 pot is too high. bring this down to 1, or 1.5, and maybe 2, you`ll have to retest to see what`s best for your condition and mods...
    http://greenhulk.net/forums/showthread.php?t=64736

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. just installed stage 1 have ?'s
    By OHIOJOE in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 10-25-2007, 07:42 PM
  2. Just installed Jerry's New Water Box today!!
    By NeverEndn in forum 4-Tec Performance
    Replies: 35
    Last Post: 07-21-2007, 07:09 AM
  3. Just installed the Jetworks (Pics included)
    By PWCManiac in forum Yamaha PWC Performance (2-stroke)
    Replies: 24
    Last Post: 03-05-2007, 09:39 AM
  4. Just installed my digital boost and A/F ratio gauges
    By Green Hulk in forum 4-Tec Performance
    Replies: 26
    Last Post: 01-25-2006, 06:36 PM
  5. Will I see any increase with just installing a Solas 14/19R
    By rxp_boy in forum 4-Tec Performance
    Replies: 6
    Last Post: 11-19-2005, 11:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •