Results 1 to 5 of 5
  1. #1

    Join Date
    Sep 2008
    Location
    so-cal , az next
    Posts
    35

    Honda noise on r12x

    My '03 R12x makes a squeal or screech under boost,and disappears on backing off throttle(otherwise it still runs the same as always).It's always been properly maintained (oil changes/filter annualy)and is started up regularly during winter in an enclosed garage.One more thing,when changing battery I found a piece of black plastic tubing about 32" long and 1/8" i.d. and could not find any place it might have come from or anything disconnected.I don't know if this has anything to do with the noise.Any ideas?


  2. #2
    cigarlust's Avatar
    Join Date
    Apr 2008
    Location
    Funky town (Fort Worth TX)
    Posts
    1,171
    +1
    2
    If you are still on the original pump parts... it's time to rebuild it. Costs 50 bucks...

  3. #3
    Quote Originally Posted by dynamike35 View Post
    My '03 R12x makes a squeal or screech under boost,and disappears on backing off throttle

    <snip>

    I found a piece of black plastic tubing about 32" long and 1/8" i.d.
    If it only does it under boost, I'd be looking for a pressure leak from the intake tract... more than likely, where that hose comes from, is where you're getting the squeal from.

  4. #4
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Location
    Jax, Florida
    Posts
    872
    +1
    1
    Run it in the water, tied to the trailer with the seat off at the boat ramp.
    You can tell more than when riding it.

  5. #5

    Join Date
    Sep 2008
    Location
    so-cal , az next
    Posts
    35

    honda noise

    I'm convinced it has something to do with boost or that plastic line.I can rule out the pump because the boat has real low hours and it has been maintained and kept greased and never had junk sucked up in it.The "trailer trick" is probably my next step looking for a vacuum/pressure leak.problem is the R12x is so packed it's a pita to look for anything.The crazy thing is it runs as good as always,and I was hoping someone had the same issue and could say what they found.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Noise on 2007 Ultra
    By ec1 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-23-2009, 04:31 PM
  2. Strange noise on RXPX
    By KirkF350 in forum 4-Tec Performance
    Replies: 18
    Last Post: 03-01-2009, 05:06 PM
  3. SC noise on larger SCs?
    By Vern in forum 4-Tec Performance
    Replies: 14
    Last Post: 10-31-2008, 05:30 AM
  4. noise on rxpx found!!
    By IM2FAST4U in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-26-2008, 11:36 PM
  5. What's with all the honda hate on the net?
    By J3ff in forum Honda Open Discussion
    Replies: 17
    Last Post: 02-21-2007, 09:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •