Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Speed Run Today

  1. #1
    Peligroso's Avatar
    Join Date
    Apr 2005
    Location
    Summerville, SC
    Posts
    74

    Speed Run Today

    I got worried after FRS #1 when I was only clocked at 66.9mph when I was hitting 70.3 with a full tank of gas the weekend before. So, I went out today to see if I could get better numbers under different conditons and here are the results.

    Speed Run:
    Date: 5/08/2005
    Air temp: 80F
    Water Temp: 80F
    Gas: 1/3 tank
    Top Speed 71.3mph by GPS
    Location: St. Marys River, GA.
    Water very small chop
    RPM: 8100 to 8150
    Cross Wind: 7mph
    Barometric Pressure: 26.1"Hg (F)

    Now, the only thing I am worried about was I was hitting 70.3 with a full tank of gas a month ago and only 68.7 today, but the temp was only 71F outside and 67F in the water a month ago. So, I am assuming that with the higher temp, that will mean warmer water cooling the sea doo and therefore causing me to lose some speed. If this is correct, please let me know.

    I am running PPG Lvl 1, Solos Impeller with the PPG repitch, RIVA top loader Intake grate as my mods.


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,983
    +1
    1,900
    thats good numbers Jon!

    Yes, the warmer the water the less power you will make. The intercooler is cooled by lake water.

  3. #3
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    80 degree water temp? I want to be where you are! Those are good numbers given the temp, I'm guessing. I definitely need a repitch on my PPG Level 1. Jon, did you have to get yours repitched after getting the Solas initially from PPG?

  4. #4
    Peligroso's Avatar
    Join Date
    Apr 2005
    Location
    Summerville, SC
    Posts
    74
    rx4pain, no I have not had it repitched yet. I will do that when I get the venturi, 2 degree wedge, and extend R&D nozzel put on.

  5. #5
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    Yeah me too, needing a repitch, but your RPM's are a bit better than mine. I'm lucky to see 8050...and the air temp has yet to reach above 70 degrees here. Mostly mid to low 60's. I just put the venturi on and haven't really had a good run with it. This season I just put the Level 1 on with the pump wedge at the same time.

  6. #6
    Peligroso's Avatar
    Join Date
    Apr 2005
    Location
    Summerville, SC
    Posts
    74
    rx4pain - Hopefully when I ge to that point I will be posting bigger numbers then. Will be happy just to see 75 though.

    Jerry - thanks for the reply, feel a little better now. I know it was mentioned before, but could not find it on SDN, so figured I would ask. GP also mentioned that they are working on something to help keep the engine cooler, guess I will have to keep an eye out for that. He talks about it on my post concerning this on SDN.

  7. #7

    Join Date
    Apr 2005
    Location
    Augusta GA
    Posts
    720
    Hulk is correct he IC get's its water fomr the lake of water you are ridding in. That's why the AM Ic works much better. As far as the impeller yes yes, yes, get that sucker repitched makes the world of diffrent. It took PPG two pitches to get the sweet spot in my impeller and that sucker is pulling harder. I Will have my other repitched solas on tomorrow and I am now running the power filter. i talked to GP and he asured me that this one I will gain some on top end as well as keeping the ninding sicking acceleration that the other one gave me. I will be testing it out tomorrow so I will let you guys know how it works.

    04 RXP
    Riva grate
    PPG repitched Solas
    OPAS block offs,
    Riva Sponsons
    70.5mph

    Tomorrow
    Full stage one - the wedge
    Another repiched solas
    ????????mph we will see

  8. #8
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    I hope GP is keeping track of his pitches. I would just like him to pitch mine the same as someone with the same mods. Like you Jrsrxp, I have just about the same set up as you - wedge and all, but I got the venturi too? Not sure if that really matters. I'm hoping to get the right (or pretty darn close) pitch when I send it in. I'm not the type to pull the pump every week, if you know what I mean.

  9. #9

    Join Date
    Apr 2005
    Location
    Augusta GA
    Posts
    720
    RX,
    I think I would spend the money in the ventura and not the wedge. Just MO. You still here mix reviews about the wedge. My next move was going to be the SC impeller and cluch, but after talking to Glen I am thinking about the new Stock ECU. It has a nice price tag @ $1,500 but I think I will be able to do more with out worrying abou t the AF mixture down the line. time will tell

  10. #10
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    I guess we're at that point where every item is an expensive one. I got the wedge mostly because my lake (98% of the riding I do) has lots of early morning glass. If I lose some top end in the chop, well I guess I'll just have to have fun with the acceleration from the SC impeller - my next mod.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 260X top speed run today.
    By DWRAT in forum Kawasaki PWC Performance (4-stroke)
    Replies: 31
    Last Post: 10-01-2009, 01:38 AM
  2. Today's Speed Run Results
    By SeaGoat in forum 4-Tec Performance
    Replies: 14
    Last Post: 12-31-2008, 05:09 PM
  3. How do these speed runs compare with yours???
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-03-2007, 06:51 PM
  4. New Jersey End of Season Ride & Speed Runs...Seaside Hei
    By ramnj in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 09-23-2005, 09:10 AM
  5. First Radar Runs Today
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-02-2005, 09:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •