Results 1 to 6 of 6

Thread: speed sensor

  1. #1

    speed sensor

    I was testing out my new ride plate and forgot to screw back on the speed sensor, don't know if that is the correct term. Long story short I ripped it off while riding and notice cause the gauge went blank , fuses are good. Ever happed to anyone?


  2. #2
    srxboy's Avatar
    Join Date
    Sep 2009
    Location
    minneapolis
    Posts
    126
    This sounds like something I would do. Good luck

  3. #3
    Nothin' runs like a Deere IowanGPR's Avatar
    Join Date
    Sep 2006
    Location
    Waterloo, IA
    Posts
    1,608
    Same thing happened to me 3 years ago... I had been contemplating removing it myself but my ignorance made up my mind for me. No problem I would leave it.

  4. #4
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45
    Quote Originally Posted by GPR View Post
    I was testing out my new ride plate and forgot to screw back on the speed sensor, don't know if that is the correct term. Long story short I ripped it off while riding and notice cause the gauge went blank , fuses are good. Ever happed to anyone?

    are you saying just the speedo went blank on the insruments? or the whole instrument cluster?

  5. #5
    Yep , completely blank

  6. #6
    Quote Originally Posted by GPR View Post
    Yep , completely blank
    speedo should read 0... you have nothing, no fuel level no blinking light nothing?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Spare Wave _____ Speed Sensor Wheel?
    By kingstretch in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 06-11-2008, 09:50 AM
  2. Speed Sensor
    By beerdart in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 10-27-2007, 01:03 PM
  3. Speed Sensor Positioning on 94 SLT750
    By utahnewbie in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-01-2007, 08:48 AM
  4. Lost speed sensor wheel!
    By Minx20 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-17-2007, 09:56 PM
  5. Speed Sensor...
    By Alaska05RXT in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-24-2006, 06:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •