Results 1 to 10 of 10
  1. #1
    Thumpem's Avatar
    Join Date
    Sep 2007
    Location
    Kemblesville Pa
    Posts
    31

    2005 1300 Oil Pump

    I am trying to reinstall the oil injection system on a ski that was converted to pre-mix. I purchesed a used pump from a greenhulk member.when I started to install the pump I noticed that the book shows the cable mount coming off the end plate of the pump. My pump does not have that cable mount. Do I have the wrong pump?


  2. #2
    I`m pretty sure you need this bracket:
    is it still bolted to the front cover?
    Last edited by Pale Rider; 01-19-2010 at 05:23 PM.

  3. #3

    Join Date
    Jul 2009
    Location
    Nor Cal
    Posts
    85
    Quote Originally Posted by Thumpem View Post
    I am trying to reinstall the oil injection system on a ski that was converted to pre-mix. I purchesed a used pump from a greenhulk member.when I started to install the pump I noticed that the book shows the cable mount coming off the end plate of the pump. My pump does not have that cable mount. Do I have the wrong pump?

    the cable mount is a separate piece...you probably have the right pump just need the mount

  4. #4
    Thumpem's Avatar
    Join Date
    Sep 2007
    Location
    Kemblesville Pa
    Posts
    31

    Bracket

    I dont have the bracket, I did notice the mounting holes there for it.
    I looked on the Riva parts page and they didnt show a bracket.
    anyone ideas on finding one.
    Thanks

  5. #5

    Join Date
    Jul 2009
    Location
    Nor Cal
    Posts
    85
    try classified section...start a wanted ad..im pretty sure someone out there has one

  6. #6
    Thumpem's Avatar
    Join Date
    Sep 2007
    Location
    Kemblesville Pa
    Posts
    31
    Been a member for two years but dont have enough posts to post a WTB.
    Do a lot of reading, just not much to say.

  7. #7

  8. #8
    post some pics of your pump, make sure you have the part that connects the pump to the crank...

  9. #9
    Thumpem's Avatar
    Join Date
    Sep 2007
    Location
    Kemblesville Pa
    Posts
    31
    Thanks Pale, part is on the way. I have the pump coupling.

  10. #10
    Quote Originally Posted by Thumpem View Post
    Thanks Pale, part is on the way. I have the pump coupling.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 vx110 oil pump
    By neverenoughx2 in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 06-25-2013, 03:16 PM
  2. FS 1300 oil pump and related parts...
    By Pale Rider in forum Yamaha Classifieds
    Replies: 1
    Last Post: 10-09-2010, 08:18 AM
  3. FS gpr 1300 OIL PUMP
    By saltysteve in forum Yamaha Classifieds
    Replies: 2
    Last Post: 07-21-2010, 06:38 AM
  4. WTB 1300 Oil Pump Bracket and Cable stop
    By Oneboss302 in forum Yamaha Classifieds
    Replies: 11
    Last Post: 05-18-2010, 05:55 PM
  5. FS 04 1300 oil pump
    By wakewhornc in forum Yamaha Classifieds
    Replies: 3
    Last Post: 09-15-2009, 09:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •