Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Never Time To Ride antoniodef's Avatar
    Join Date
    Nov 2006
    Location
    Waterford, Michigan
    Posts
    1,169

    R&D Impeller Cone

    Has anyone tried the R&D impeller cone? Notice any improvement? I tried searching and could not find any feedback on it.

    http://www.4-tecperformance.com/inde...roducts_id=908


  2. #2
    Never Time To Ride antoniodef's Avatar
    Join Date
    Nov 2006
    Location
    Waterford, Michigan
    Posts
    1,169
    Anyone???

  3. #3
    sweetbats's Avatar
    Join Date
    Mar 2008
    Location
    Glen Allen, VA
    Posts
    238
    I removed my stock one and do not run one at all.

  4. #4
    richrxp's Avatar
    Join Date
    Jun 2006
    Location
    Netherlands
    Posts
    949
    +1
    1
    Quote Originally Posted by sweetbats View Post
    I removed my stock one and do not run one at all.
    +1 I run without also.
    The nosecone gives no improvement at all.

  5. #5
    but it (stock or R+D) does keep water out of the prop splines, prbably a good idea, specially in salt water, ive seen the splines rust, then strip, time for a new drive shaft and prop at that point.

  6. #6
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    I run R and D nose cone without any issues. I have never had a nose cone back off on me, so why not run it, makes it easier to put pump back on.

    I have not seen any gains or losses from running a nose cone.

  7. #7
    salsa's Avatar
    Join Date
    Sep 2007
    Location
    des moines iowa
    Posts
    134
    I gotta question. Are you talking about the R&D cone at the back of the pump? Anti cavitation cone I believe it's called.

  8. #8
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    just stick some marine grade grease on your splines on both ends to keep them from corroding inside. I run mine naked, without it,

  9. #9
    richrxp's Avatar
    Join Date
    Jun 2006
    Location
    Netherlands
    Posts
    949
    +1
    1
    Quote Originally Posted by faster7581 View Post
    but it (stock or R+D) does keep water out of the prop splines, prbably a good idea, specially in salt water, ive seen the splines rust, then strip, time for a new drive shaft and prop at that point.
    No rust when you remove your nosecone,there is always some corrosion even with the cone on.
    Put grease on your splines,and after riding spray some lube if your still worried.
    I also run in salt water,and no problems whatsoever.
    No worries.

  10. #10
    Never Time To Ride antoniodef's Avatar
    Join Date
    Nov 2006
    Location
    Waterford, Michigan
    Posts
    1,169
    Quote Originally Posted by salsa View Post
    I gotta question. Are you talking about the R&D cone at the back of the pump? Anti cavitation cone I believe it's called.
    Yeah...click on the link I posted and it will take you to it. I was just wondering if anyone saw an improvement with it. According to Skoepp, he runs it with no improvement. That is what I was wondering. I know there is a cone from WetWolf, Adjust-A-Thrust, that seems to offer a noticeable improvement.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Taking off the impeller cone
    By Hecyan in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-20-2006, 11:18 PM
  2. Impeller cone ???
    By slow1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 07-14-2006, 11:19 AM
  3. Pump oil and impeller cones
    By Vern in forum 4-Tec Performance
    Replies: 4
    Last Post: 03-23-2006, 03:40 PM
  4. Impeller cone and rideplate
    By Ronn25 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 03-13-2006, 09:10 PM
  5. New Aluminum/SS Billet Impeller Cone from Riva
    By Red Devil in forum 4-Tec Performance
    Replies: 8
    Last Post: 03-09-2006, 05:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •