Results 1 to 2 of 2
  1. #1
    AWA Member 32DegH2O's Avatar
    Join Date
    Aug 2006
    Minneapolis, Mn.

    Pump Nozzle Blades

    Has anybody removed the pump nozzle blades?...did it make any difference? One of mine, the front edge is chipped away and 2 blades are out of alignment with the stator and is interrupting water-flow. I was thinking of just removing them all together. Any input would be great...thanks!

    P.S. I'm use to Polaris pumps which do not have blades in them so wondering if they really help.

  2. #2
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Fercho did this years ago and lost significant speed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. hey what pump nozzle?
    By Tanny in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 05-19-2007, 03:01 PM
  2. which pump nozzle ring?
    By RXPteamtimebomb in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-18-2007, 07:19 PM
  3. chips out of 2 stator blades...
    By Bilgewiper in forum Polaris Open Discussion
    Replies: 4
    Last Post: 04-04-2007, 09:42 PM
  4. 95 xp pump and nozzle
    By Blackhardt in forum 2-Stroke Performance
    Replies: 10
    Last Post: 01-21-2007, 09:30 AM
  5. have anyone try skat-trak 4 blades 10/21? need some advise!
    By novice_4 in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-14-2006, 08:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts