Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    gp1200r lagging at take off

    hi i just got a 2001 gp1200r with 45hrs an it seem like it takes abit to get up an going from a dead stop is this the same with all gp's the ski rus fine but just slow at start


  2. #2
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    cavitating, probably needs a pump plug kit and new intake grate(factory one is dangerous)
    check this out
    http://www.cajundude.com/pumpshoe.htm

  3. #3
    it just feels like the motor is lagging down bottom end my mate has the same ski at they both do the same

  4. #4
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    if it feels like the tires spinning on a car till 11mph then like a bat out of hell it needs a ppk and seal the shoe...

  5. #5
    i know what ur saying but its the motor that laging not the pump

  6. #6
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    so maybe the carbs need rebuilding then if its a bog.... ever been done?

  7. #7
    Moderated
    Join Date
    Oct 2006
    Posts
    3,711
    sounds like the carbs need to be rebuilt, they go funny after about 120+ hours if they are not touched....

  8. #8
    not that i know of i was going to do them at 50hrs

  9. #9
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    Quote Originally Posted by kaotic racing View Post
    not that i know of i was going to do them at 50hrs
    carbs are a major cause of these engines seizing,,, i would get on it quick

  10. #10
    just been told carbs have just been redone b4 i got it is this just how 2000 model plus gpr's run

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 RXP - cavitation at take off
    By TheGunMan in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 05-05-2013, 11:00 PM
  2. Gp1200r Bogging On Take-off
    By nabbs89 in forum Yamaha PWC Performance (2-stroke)
    Replies: 26
    Last Post: 04-09-2013, 06:08 AM
  3. TX 1200 bog at take off??
    By IndyAl in forum Polaris PWC Performance
    Replies: 4
    Last Post: 07-23-2012, 12:46 PM
  4. Replies: 3
    Last Post: 10-04-2011, 04:43 PM
  5. 02 FX140 REV Limiter at take off.
    By [email protected] in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 10-05-2010, 10:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •