Results 1 to 5 of 5
  1. #1
    Benazz's Avatar
    Join Date
    Sep 2008
    Location
    Vic, Australia
    Posts
    61

    Rxp - Overheated, wont start

    Hi guys,

    Had a pipe come off my ski while on the lake yday (it was a coolant pipe) and the engine overheated and the buzzer came on an it stopped. Got towed in after a near miss with the rocks. Problem is now the ski wont start. it will crank but not fire up.

    ive had the plugs out and it all seems fine, display does however have chk engine on it. any ideas on what i should try? im a bit concerned i cant flush it and its full of salt.

    im running open loop.

    cheers for any advice!


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Did it stop by itself or did you stop it? If it stopped by itself, it could be bad. Have you checked the compression? If it overheated badly, the rings might be stuck in the pistons... Ron

  3. #3
    Benazz's Avatar
    Join Date
    Sep 2008
    Location
    Vic, Australia
    Posts
    61
    The beeper went off and i slowed it down and turned it off... wouldn't start again after that.. I'll check the compression.

    Wouldn't the ski pickup on the overheat and shut itself off before it gets too hot to do a lot of damage? :s

  4. #4
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by Benazz View Post
    The beeper went off and i slowed it down and turned it off... wouldn't start again after that.. I'll check the compression.

    Wouldn't the ski pickup on the overheat and shut itself off before it gets too hot to do a lot of damage? :s
    Did you tow it back at idle or on plane? Pull the plugs and crank it over at wot and see if water sprays out of the cylinders.

  5. #5
    Benazz's Avatar
    Join Date
    Sep 2008
    Location
    Vic, Australia
    Posts
    61
    Thanks for the help guys,

    Took it to the dealer, on the buds it was showing heaps of errors, turns out it was due to the battery being low...
    Just happened to cause problems at the same time the ski blew a pipe and overheated. Not sure how, but i'll take it. All is well

    Cheers!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Seadoo RXP 215 - Wont start - Low coolant - Suggestions?
    By PeterLudvigsen in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-09-2016, 06:08 AM
  2. HELP! 07 RXP 215 wont start. no spark or fuel injector pulse
    By KingCobra07 in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-13-2014, 10:22 PM
  3. rxp engine wont start, whats wrong??
    By pbrxp in forum 4-Tec Performance
    Replies: 22
    Last Post: 09-13-2009, 11:14 PM
  4. Ski wont start--RXP
    By wakeborder556 in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-30-2006, 07:53 PM
  5. RXP wont start
    By werdnash2002 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-21-2005, 11:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •