Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 53
  1. #1

    98 xp limited backfires/hits rev limiter

    Here's the boat:

    98 xp limited

    Fresh motor

    Carbs rebuilt

    Re-jet 85 L 1 1/2 turn. 167.5 H 1/4 turn

    Flame arrestors

    Pre-mix

    Compression is good

    Brand new starter/Bendix (SBT)

    Brand new battery

    Stator checks good

    mini tach sayin 3500 at idle/6k- 6500 when it backfires/runs like crap(sounds like hitting rev limiter) I wil also add I do not believe it is really hitting 6k- 6500 rpms out of water.

    Stock Mpem boat starts and idles fine. Backfires when you gve a lil pep/flick the throttle. Back fires at motor, can see come through the pulse line.

    Second box Deans Team idles smooth give it 3/4 full throttle backfires seems to hit rev limiter.



    I have ideled the boat through the canals for about an hr to break in the motor. No problems at all. In the water when i give it 3/4 to full throttle RPM'S 5-6k and it just pushes water. It will not get on plan. Sounds like the plugs are fouled (but are not). Will also sound as if it is hitting the rev limiter.



    Any suggestions???



    If anyone could let me barrow a Mpem to check one more box that would be greatly appreciated. I'm in Harrison TWP, MI. Of, course beer would be supplied.



    Email [email protected]

    Thanks,

    Wagz


  2. #2
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    Check your reed valves toward the light make sure they seal right,
    also backfiring will most of the times crack your reed petals. check those

    High settings should be set to 0.

    you are cavitating. thats why you wont plane out the water and thats why you are hitting the rev limiter.
    Check your impeller to wear ring clearance.
    check your wear ring and Impeller.
    Check your carbon ring, does it leak a bit of water inside your hull while your in the water? if so you might have a worn out carbon ring, I use seal carriers, i feel they are more reliable of maintained properly.
    you can purchase these for about 30-40 bucks new.

  3. #3
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Quote Originally Posted by WAGZ102 View Post
    Here's the boat:

    98 xp limited

    Fresh motor

    Carbs rebuilt

    Re-jet 85 L 1 1/2 turn. 167.5 H 1/4 turn-The screw settings are ok to start out with. You may end up lower on the HS screws but I would not turn them in without some plug readings to confirm.

    Flame arrestors-I assume you are still running the accel pump with that jetting?

    Pre-mix

    Compression is good

    Brand new starter/Bendix (SBT)

    Brand new battery

    Stator checks good

    mini tach sayin 3500 at idle/6k- 6500 when it backfires/runs like crap(sounds like hitting rev limiter) I wil also add I do not believe it is really hitting 6k- 6500 rpms out of water.-Does the stock tach agree?

    Stock Mpem boat starts and idles fine. Backfires when you gve a lil pep/flick the throttle. Back fires at motor, can see come through the pulse line.

    Second box Deans Team idles smooth give it 3/4 full throttle backfires seems to hit rev limiter.



    I have ideled the boat through the canals for about an hr to break in the motor. No problems at all. In the water when i give it 3/4 to full throttle RPM'S 5-6k and it just pushes water. It will not get on plan. Sounds like the plugs are fouled (but are not). Will also sound as if it is hitting the rev limiter. -I am not sure what you are saying here. Like Ultramax, I think it sounds like it is spinning up but not going anywhere which would indicate a problem in the pump/wear ring/prop/shaft seal area.

    That said, what does it do if you try to accelerate gradually?



    Any suggestions???



    If anyone could let me barrow a Mpem to check one more box that would be greatly appreciated. I'm in Harrison TWP, MI. Of, course beer would be supplied.



    Email [email protected]

    Thanks,

    Wagz

    Was the rest of the fuel system replaced/cleaned?

  4. #4

    Join Date
    Nov 2009
    Location
    Irvington, AL
    Posts
    23

    Timing?

    You didn't mess with the pick-up coil by chance, did you?

    The reed valves would be my first thought but if your carbs aren't in sync, this will also cause backfiring.

    Look at your spark plugs, see if they are burning even.

  5. #5
    Not spinning up at all. Pump was gone through as well as the prop. Everything checked out ok. Carbs are in sync. Plugs are burning even and fine. (little dark as mixed double oil.) No acc pump.

  6. #6
    Kidd800XP's Avatar
    Join Date
    Apr 2008
    Location
    Piedmont,Al
    Posts
    343
    Quote Originally Posted by WAGZ102 View Post
    Not spinning up at all. Pump was gone through as well as the prop. Everything checked out ok. Carbs are in sync. Plugs are burning even and fine. (little dark as mixed double oil.) No acc pump.

    If your not running the accel pump i would go up to 95 on the lows.

  7. #7
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Quote Originally Posted by Kidd800XP View Post
    If your not running the accel pump i would go up to 95 on the lows.

    +1

  8. #8

    Join Date
    Jul 2005
    Location
    Ohio
    Posts
    441
    +1
    1
    ALL the above is excellent advise but none matters until you.........

    Time your friggin motor!!

    TLR

  9. #9
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    There is a distinct difference between ignition cutoff from hitting the rev limiter to an actual engine backfire. I doubt seriously that it is backfiring.

    Your pickup ear(s) could be broken, resulting in it breaking up, or doesn't this ski have a TPS TLR?

    Changing boxes confirms it is something you haven't found yet, and it's not the MPEM.

  10. #10
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    No TPS on '98.

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 or 98 XP limited
    By h400exrydr84 in forum 2-Stroke Performance
    Replies: 16
    Last Post: 09-08-2011, 02:52 PM
  2. FS Brand New 98 XP Limited OEM Seadoo MPEM
    By Slow 91 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 02-15-2011, 01:52 PM
  3. What to look for on 98 XP Limited.
    By WavruninPWC in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-31-2009, 03:23 AM
  4. Question on 98 XP LIMITED
    By Azzo in forum 2-Stroke Performance
    Replies: 3
    Last Post: 03-02-2009, 10:27 PM
  5. 98 xp limited
    By hipv323 in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-30-2008, 08:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •