Results 1 to 8 of 8
  1. #1
    brad2510's Avatar
    Join Date
    Aug 2005
    Location
    Jacksonville, FL
    Posts
    595

    Program Module PT#278002043

    Well It looks like i may have to replace this part. Its the party that holds all the fuses. The hole black box. My question is has anyone had to replace this? How much did it cost? It is to late for me to call the dealer. The reason that i am going to replace it is because when you pull the key off it makes this buzzing noise and it won't stop unless you unplug it.


  2. #2
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    Here is what my dealer says:
    MODULE PROGRAM.*PROGRAM. MODULE (278002043) $444.97

    This is the famous MPEM. Are you sure that is bad and it isn't a problem with one of the relays? It sounds like a relay to me.

  3. #3
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    sounds like your TOPS valve is going bananas... pretty common and have seen it quite a few times.

  4. #4
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    Quote Originally Posted by Shibby1485
    sounds like your TOPS valve is going bananas... pretty common and have seen it quite a few times.
    But the TOPS valve is in a completly different place. THat is on the engine, what he is talking about is in the storage area.

  5. #5
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    good point... at the same time he didn't specify where the buzzing noise is coming from. He only said the only relief for the problem is by pulling the harness out of the MPEM.

    we need more info

  6. #6
    brad2510's Avatar
    Join Date
    Aug 2005
    Location
    Jacksonville, FL
    Posts
    595
    No the sound is coming from the fuse panel itself. the sound goes away if you pull the top fuse on the left side. the third fuse from the top on the right side and also the bottom fuse on the right side. if anyone of those fuses are in there place it makes the buzzing noise. The buzzing starts about 5 seconds after you remove the kill switch. what ever info you guys might need to come up with something i would be glad to tell you what i can. I really need help. If i order this $440 part and that is not the problem i dont think you would be able to return it. keep in mind i noticed this problem when the kill switch would not turn off the ski intermittedly. sometimes it worked sometimes it didn't. I know you guys know your **** what do you think?

  7. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    i'm not sure i have the answer to your problems... but as a last resort if it comes down to replacing the MPEM maybe i can help you out with saving money on that, so let me know.

  8. #8
    brad2510's Avatar
    Join Date
    Aug 2005
    Location
    Jacksonville, FL
    Posts
    595
    well i think it fixed itself. Went outside unpulged the whole thing took all the fuses out put it all back and it works fine now. No more noise. So we will see what happens. Thanks steve i might end having to take you up on that offer.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB 2005 SeaDoo RXP 215 HP 4-TEC Program Module CPU CDI
    By RNX in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 10-16-2011, 01:16 PM
  2. FS 05 Program Module
    By 1 FAST VE in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 05-16-2010, 11:05 AM
  3. Reflash to newer program for Rotax Racing ECU
    By Green Hulk in forum 4-Tec Performance
    Replies: 67
    Last Post: 01-08-2006, 03:41 PM
  4. What video program editor u use?
    By PMart317 in forum Videos & Pictures
    Replies: 1
    Last Post: 10-20-2005, 06:49 PM
  5. re program stock ecu
    By INDY27 in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-09-2005, 12:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •