Results 1 to 8 of 8
  1. #1
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1

    stage2 cavitating

    Ok took the ski out yesterday only for an hour. Seems the pump will only suck air to the point it will bang the limiter and i mean bang 8300 on stock ECU if i run slow and not hole shot it will rev to 7900 and will pull 70.4.after thinking i sucked something up decided to put in reverse to try and clear it.Agiain it will bang the limiter reverse and not go anywhere it will stay reving at 8300 till the hi temp warning and it shuts down.Have not removed pump yet will do today but looking at the impeller and wear ring not a mark on either(both new three weeks ago and only been out three times.

    any help would be a god send


  2. #2
    buddydoo's Avatar
    Join Date
    Oct 2005
    Location
    houma
    Posts
    958
    +1
    9
    Dam banana,I've been having the same problem with my rxp.It's seems to do it after a good top end run.I changed the carbon seal and put a o-ring in back of the boot and still no luck.Ordered a boot and the seal sleeve from jerry and hopfully that will fix the problem.

  3. #3
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    buddydoo this thing is starting to be a pain in the ass let me know if it works.


    Rob

  4. #4
    Is the pump neoprene seal ok? Pump support OK, not cracked?...just throwing that out there?...PR...

  5. #5
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    well guys may of found the problem removed pump check the big black seal and looking at it it seemed to be flatter half way round compared to the other side. Removed and fitted in pump shoe and shore enough has eggs are eggs only one side of the seal was higher than the pump shoe meaning the pump wasnt sealing and suckin in air.So down the shop i went and got the last one in town will fit tonight and check tomorrow.

  6. #6
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    Jerry if your reading this i have a 15/20 solas and only reaching 7900 best way.How marry mm do i need to take out the prop to get 8100-8200 thanks

  7. #7

    Join Date
    Apr 2005
    Location
    Elysian Fields,Tx
    Posts
    358
    2 MM should get you pretty close,I think it figures about 100 to 150 per MM.

  8. #8
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    thanks for your in put after testing will tweek the prop

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Prop boot and cavitation
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 01-28-2011, 08:09 PM
  2. Performance Fuel Pump,is it needed for stage2?
    By novice_4 in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-03-2006, 10:06 PM
  3. R&D Anti Cavitation Cone
    By Kinchyle in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-02-2006, 10:46 AM
  4. Cavitation issue: worried
    By BDNJ in forum 4-Tec Performance
    Replies: 62
    Last Post: 09-13-2005, 08:21 AM
  5. Post on cavitation
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-04-2005, 10:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •