Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    TDR's Avatar
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    727
    +1
    10

    Seadoo 1998 XP Limited Trouble

    Hi,

    For about two weeks our ski has been playing up. Today we launched the ski and for about 30min it was working well but still at open throttle the ski didnt sound like it was reaching maximuim potential, the ski sounded like it was chocking at high rpms.
    It reached only 50-55mph fairly calm weather. I know it can go more because a couple months ago when we first brought the ski i reached 60-61mph. It has been nothing but trouble from thier, because we had just rebuilt the carbs, and we fitted Hydro-Turf and forgot to fill the holes up and water got into the carbs because the hull was filling up with water.

    Now this, well back to what happened today, after those 30 min i came back in to take a break then i went back out and i was holding it open throttle and still 50-55mph, then suddenly rpms dropped and it was idling at around 1000rpm when it should be at 1300-1500rpm. Then i held the throttle wide open again and the ski had no power at all it was only revving up to 3000rpm at full throttle it sounded really bad like somthing was holding it back.
    Im not sure if the air/fual is to rich or to lean, we dont know what is wrong with the ski and this has been happening for the past 3 times we have taken the ski out, because we would go home flush the ski and it would correct itself. Then go out the next week and the same problem. We have really had enough, could any please help us on this problem

    Thanks Nick.


    Seadoo Xp 1998 Limited
    Solas Prop 15/20
    Finger Throttle
    Worx Intake Grate
    Hydro-Turf


  2. #2
    How do the spark plugs look mate? Sounds like they could be fould...

    Take them out and post some picks up

  3. #3
    TDR's Avatar
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    727
    +1
    10
    Here are the pics of the spark Plugs and the Head.
    I think we need new spark plugs
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG00097.jpg 
Views:	69 
Size:	438.4 KB 
ID:	158271   Click image for larger version. 

Name:	IMG00098.jpg 
Views:	94 
Size:	422.5 KB 
ID:	158272  

  4. #4
    Bet that's your issue mate! $9 AUD fix at the most

    Always should have a spare set of them on you when your out too....

  5. #5
    TDR's Avatar
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    727
    +1
    10
    Thanks for your help mate.

  6. #6
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    If you havent done this yet...read this

    http://greenhulk.net/forums/showthread.php?t=27314

  7. #7
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    I think you need to do a compression check.

    When you flush the engine you are idling without a load. If it can run at all and has not lost a bearing it will idle on the trailer ok 9 times out of 10.

    Being that it is a '98 it could well be your plugs but you need to check the compression before you ride it again because if you have siezed it and keep riding it the rod on the piston that siezed WILL LET GO. When that happens, your repair bill will head into orbit.

  8. #8
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    Quote Originally Posted by KrunchovXPL-GTX-RX View Post
    I think you need to do a compression check.

    When you flush the engine you are idling without a load. If it can run at all and has not lost a bearing it will idle on the trailer ok 9 times out of 10.

    Being that it is a '98 it could well be your plugs but you need to check the compression before you ride it again because if you have siezed it and keep riding it the rod on the piston that siezed WILL LET GO. When that happens, your repair bill will head into orbit.
    +1

  9. #9

    Join Date
    Oct 2009
    Location
    derbyshire
    Posts
    76
    i had exactly the same issue with 99 xpl. i purchsaed it with a full engine rebuild and after a few hours the same problem started. took it back to my local seadoo dealer and they said it was the carbs..... so they stripped them. next time i took it out it was doing the same again. it went back to the dealer again... to be told it was me not the ski! lol. they stripped it again. when it went back out after about 2 mins it seized solid on the front pot and wrecked the crank too. cost me £600 to rebuild it.

  10. #10
    TDR's Avatar
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    727
    +1
    10
    Thanks guys for your help i will come back and tell you how the ski is going after we get it up and running well, and one other thing how long do spark plugs last?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts 1998 XP Limited Waterbox Powervlave Assembly
    By scottie mac in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 05-23-2016, 02:13 AM
  2. 1999 seadoo 951 xp limited carb help
    By t71-racing in forum Sea Doo How To & FAQs
    Replies: 1
    Last Post: 05-07-2013, 04:45 PM
  3. WTB 1998 XP Limited Storage Lid
    By Slow 91 in forum Sea Doo 2 Stroke Skis
    Replies: 5
    Last Post: 05-27-2010, 06:58 AM
  4. Need Help! 1998 XP LIMITED wont start
    By crunkz06 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 03-03-2009, 06:55 PM
  5. 1998 xp limited
    By jackmonster1 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 02-15-2008, 12:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •