Results 1 to 4 of 4
  1. #1

    Oil Light going off

    Anyone know the reason my oil light goes on? I changed the oil to make sure I had the exact amount and it's still going off. It runs pefectly fine but if I rip for a second and let off then go to hit the throttle it goes into limp mode for 3 seconds.


  2. #2
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Did you change your oil filter? How many hours? Ever had a s/c washer failure?

  3. #3
    Nedo69's Avatar
    Join Date
    Feb 2009
    Location
    Wollongong, Australia
    Posts
    67
    I just solved the same problem in my RXP. It was the oil pressure sensor at the rear under the manifold. Mind you took a while to prove since I changed it out twice for brand new ones I bought from Seadoo and both turned out to be faulty. I ended up using one from another ski that I knew was good. No probs since!!!!!

  4. #4
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    The best test is an oil pressure guage. The service manual has the specs.
    I think the minimum readings should be 33psi at idle and 66psi at high rpm when hot.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. turn low oil light OFF when using premix??
    By KEYZBUM in forum Yamaha Open Discussion
    Replies: 13
    Last Post: 04-28-2014, 06:37 PM
  2. When exactly will the low oil light come on and go off?
    By MrBrainerd in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-17-2013, 09:39 PM
  3. 1998 seadoo xpl oil light not going off
    By harrstew XP in forum 2-Stroke Performance
    Replies: 1
    Last Post: 04-24-2012, 07:16 AM
  4. how long between the oil alarm going off and your engine is toast on oil injection?
    By jetdave56 in forum Yamaha PWC Performance (2-stroke)
    Replies: 27
    Last Post: 02-20-2011, 07:27 PM
  5. Still have the exhaust temp light, buzzer going off Now What?
    By mstennes in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-17-2007, 11:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •