Results 1 to 7 of 7
  1. #1

    Join Date
    Oct 2009
    Location
    Chadds Ford, PA
    Posts
    29

    2000 Ultra only reaches 6000rpm

    Just had carbs installed and this is the first time the ski has been ran for well over a year and a half. Ski starts right up, has a slight hesitation getting up on plane but once up runs and responds well. Only issue is it only goes to 6000rpm and I know it should reach 6700 (or is it 6800?). 2000 Ultra and speedometer FWIT read 55mph at 6000rpm.

    Any suggestions on what to fix or tweak to reach full rpm?

    --JK


  2. #2
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Are the carbs factory or aftermarket? What impeller do you have in it? Is this rpm on the factory tach?

  3. #3

    Join Date
    Oct 2009
    Location
    Chadds Ford, PA
    Posts
    29
    Quote Originally Posted by btldigger View Post
    Are the carbs factory or aftermarket? What impeller do you have in it? Is this rpm on the factory tach?
    Stock carbs, stock impeller, factory tach. Tach goes exactly to 6000 and not a blip over....

    --JK

  4. #4
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    With a stock prop and otherwise stock motor your rpm should be about 6750. The stock tach reads in 250 rpm increments. An aftermarket tack such as the tiny tach is more usefull for tunning.

    First thing to check is that the carbs are oppening fully and that the choke flaps are not partially closed. Doing a plug chop might help determine if it is getting the correct amount of fuel. The other thing to check is the pump bearings. If it has been sitting up that long there could have been water in them and they are trashed.

  5. #5

    Join Date
    Nov 2009
    Location
    Norway
    Posts
    4

    check TPS

    I`d check the trottle position sensor on the carbs. They have caused me similar problem before.

  6. #6
    I'm a living organ donor; 1 kidney since 2002. Mitch 05 Ultra 150's Avatar
    Join Date
    Nov 2009
    Location
    Naperville, Illinois
    Posts
    62

    Smile

    Double check if you get full throttle. Don't use the thumb throttle control, manually check it from the engine compartment.

  7. #7
    I'm a living organ donor; 1 kidney since 2002. Mitch 05 Ultra 150's Avatar
    Join Date
    Nov 2009
    Location
    Naperville, Illinois
    Posts
    62

    Smile

    I would also check the pump bearings and impeller.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ultra 250x full boost but only reaching 6400 rpms max! HELP
    By rich7079 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 07-27-2014, 10:08 AM
  2. 2000 Ultra 150 #3 Piston and Cylinder Failure
    By skiguy1028 in forum Kawasaki Open Discussion
    Replies: 19
    Last Post: 11-24-2013, 06:48 PM
  3. 2000 Ultra 150 speed limiter (for guest riders)
    By aviator in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 05-19-2008, 06:53 AM
  4. My 2000 ultra 150 gps'd yesterday.
    By jcc011185 in forum Kawasaki Open Discussion
    Replies: 76
    Last Post: 05-08-2008, 06:42 PM
  5. My new 2000 ultra 150
    By jcc011185 in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 08-03-2007, 05:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •