Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32
  1. #1

    Defective Powershots?

    Anybody have a problem with the powershots failing after a few months use? My powershot completely died after a few months. The Riva dealer told me that I have to send it back to R&D to see if they will give me a refund. Same thing happened to my mechanicís powershot as well after a few months of use.


  2. #2
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by tsho View Post
    Anybody have a problem with the powershots failing after a few months use? My powershot completely died after a few months. The Riva dealer told me that I have to send it back to R&D to see if they will give me a refund. Same thing happened to my mechanicís powershot as well after a few months of use.
    Dobeck makes the thing. Wonder if somebody aught to talk to them or not...........

  3. #3
    mjh3ides's Avatar
    Join Date
    Jul 2007
    Location
    Jupiter, Florida
    Posts
    6,799
    +1
    2,013
    R&D's return policy is 30 days...you may be SOL, but it's worth a shot.

  4. #4
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Talk to Glen at R&D.

  5. #5
    Quote Originally Posted by hitman View Post
    Talk to Glen at R&D.
    Do you have his number or is it on their website.

    Thanks

  6. #6
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by tsho View Post
    Anybody have a problem with the powershots failing after a few months use? My powershot completely died after a few months. The Riva dealer told me that I have to send it back to R&D to see if they will give me a refund. Same thing happened to my mechanicís powershot as well after a few months of use.
    I have seen some on a GPR but not a SHO motor yet.

  7. #7
    Ricky T's Avatar
    Join Date
    Dec 2008
    Location
    El Paso
    Posts
    65
    Quote Originally Posted by tsho View Post
    Anybody have a problem with the powershots failing after a few months use? My powershot completely died after a few months. The Riva dealer told me that I have to send it back to R&D to see if they will give me a refund. Same thing happened to my mechanicís powershot as well after a few months of use.
    If you can get your money back you should look into a true fuel/ignition controller from aem. it runs about the same $ and runs as a piggy back to your existing stock ecu base.

  8. #8
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Quote Originally Posted by tsho View Post
    Do you have his number or is it on their website.

    Thanks
    Just call the number on their site and ask to talk to Glen. He's very helpful.

  9. #9
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Quote Originally Posted by Ricky T View Post
    If you can get your money back you should look into a true fuel/ignition controller from aem. it runs about the same $ and runs as a piggy back to your existing stock ecu base.
    I have also been looking into this lately. How hard would wiring up one of these systems into our skis be? Looks like it could offer a lot of control over fuel and timing and now that we can fool the boost limiter with Jim's home made boost bleeders, we should be able to use the AEM system.

  10. #10
    CT Marsh Dredging Crew STItaxi's Avatar
    Join Date
    Jul 2008
    Location
    Madison, CT
    Posts
    975
    Quote Originally Posted by hitman View Post
    I have also been looking into this lately. How hard would wiring up one of these systems into our skis be? Looks like it could offer a lot of control over fuel and timing and now that we can fool the boost limiter with Jim's home made boost bleeders, we should be able to use the AEM system.
    Since most of these systems adjust fuel by altering the MAP or MAF sensor output going to the ECU, I'm not sure it if would be doable if you're bleeding off boost before the sensor...

    Maybe we could eliminate the need for the boost bleeder entirely and instead run some larger injectors and/or higher fuel pressure and adjust the AFC to show much lower MAP voltage to the ECU so the boost limit never kicks in?

    My other concern is making sure the unit doesn't get wet since I don't think any of the AFC's used on cars are waterproof.

    Seems like a good idea to try out though.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fx Powershot
    By Gj#6 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 02-03-2007, 10:14 AM
  2. R&D powershot adj fuel tuner
    By nickdog in forum 4-Tec Performance
    Replies: 7
    Last Post: 12-05-2006, 10:22 AM
  3. R&D grate Defective or no problem??? Help...
    By Tiburon in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-24-2006, 06:45 PM
  4. Defective Speedo Help? (+ Lesson Learned)
    By washingtonrider in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 08-10-2006, 08:55 PM
  5. FIXING THE R&D RIDE PLATE "DIP" (MANUF. DEFECT
    By ABBOTT in forum Yamaha How To & FAQs
    Replies: 58
    Last Post: 03-22-2006, 05:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •