Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 46
  1. #1
    BlackHawk's Avatar
    Join Date
    Mar 2006
    Location
    AL
    Posts
    959
    +1
    2

    Need help with RE's block offs

    Need help aligning the RE's block offs...does anyone have a tip how to do it right?
    For some reason I cant get them straight with the bottom and straight with the side.


  2. #2

  3. #3
    BlackHawk's Avatar
    Join Date
    Mar 2006
    Location
    AL
    Posts
    959
    +1
    2
    Quote Originally Posted by richrxp View Post
    Didn't really help....I'm having a problem aligning it up...for some reason when its flush on the bottom it not flush up top....not really sure is it better to have them slightly up towards the end or completely straight with the bottom.

  4. #4
    Mine don't align on the bottom and top/sides. It's just the way they are made. I've also got a gap on the leading edge. I thought I would get a better fit for the money, but not in this case.

  5. #5
    BlackHawk's Avatar
    Join Date
    Mar 2006
    Location
    AL
    Posts
    959
    +1
    2
    Quote Originally Posted by Throttlemire View Post
    Mine don't align on the bottom and top/sides. It's just the way they are made. I've also got a gap on the leading edge. I thought I would get a better fit for the money, but not in this case.
    Same here.

    Now looking to see what is the best way to set it up for what I got.

  6. #6
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by BlackHawk View Post
    Same here.

    Now looking to see what is the best way to set it up for what I got.
    The RE's are not supposed to line up with the bottom because they the hull has a hook in it. Put a straight edge on the bottom of the hull starting in front of the block-offs and make sure they are'nt hanging down in the rear. You do not want them to follow the hook in the rear of the hull. Also, the REs dont fit as well as the rivas but once installed correctly they work great.

  7. #7
    BlackHawk's Avatar
    Join Date
    Mar 2006
    Location
    AL
    Posts
    959
    +1
    2
    Quote Originally Posted by speedskixp View Post
    The RE's are not supposed to line up with the bottom because they the hull has a hook in it. Put a straight edge on the bottom of the hull starting in front of the block-offs and make sure they are'nt hanging down in the rear. You do not want them to follow the hook in the rear of the hull. Also, the REs dont fit as well as the rivas but once installed correctly they work great.

    Okay...the bottom is straight...is it better to go slightly up or does it matter?
    What about the mid section of the RE's should they be straight...that's the one I'm having trouble with...if the bottom is straight the mid section is off...but if I get the mid section straight too, then there is a slight lift on the bottom.

  8. #8
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,132
    +1
    821
    Quote Originally Posted by speedskixp View Post
    The RE's are not supposed to line up with the bottom because they the hull has a hook in it. Put a straight edge on the bottom of the hull starting in front of the block-offs and make sure they are'nt hanging down in the rear. You do not want them to follow the hook in the rear of the hull. Also, the REs dont fit as well as the rivas but once installed correctly they work great.
    +1
    I recently took mine off of my RXT which is a little different but I redrilled all the holes to have more adjustability to them. Before they had a hook to them, now they are straight. Best advice I can give is dry fit them first. Then once you are happy with the fitment, put Right stuff silicone around the holes and on the edges and fit them up. They work great but fitment is a little bit of a pain.

  9. #9
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by BlackHawk View Post
    Okay...the bottom is straight...is it better to go slightly up or does it matter?
    What about the mid section of the RE's should they be straight...that's the one I'm having trouble with...if the bottom is straight the mid section is off...but if I get the mid section straight too, then there is a slight lift on the bottom.
    With the REs, I like to have them slightly angled up at the rear bottom.

  10. #10
    Doel Tiburon1264's Avatar
    Join Date
    Nov 2007
    Location
    Jacksonville, Florida
    Posts
    2,343
    +1
    11
    Quote Originally Posted by BlackHawk View Post
    Didn't really help....I'm having a problem aligning it up...for some reason when its flush on the bottom it not flush up top....not really sure is it better to have them slightly up towards the end or completely straight with the bottom.
    BlackHawk,

    I have them flush with the bottom. I had some problems on the top. I used The Right Stuff to seal they look good and clean. I don't have no drag or proposing going on. I would not worry about the top the most improtant is the bottom to be flush with the hull. I hope you to care of that three blade impeller you was talking me about at the Hydro.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with 03 GTX shutting off at WOT
    By 03gtx in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-09-2014, 11:40 PM
  2. i need help with jet block
    By prmazdarx7 in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 06-09-2010, 06:26 PM
  3. Please help with gp1300 oil block off
    By amf133 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-28-2010, 10:16 PM
  4. need help with oil injection block off 2006 gp1300rs
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-06-2007, 11:34 AM
  5. help with installing oil block off kit
    By joshxp in forum Polaris Open Discussion
    Replies: 4
    Last Post: 03-30-2007, 11:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •