Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1
    spud's Avatar
    Join Date
    Jul 2006
    Location
    Oceanside, California
    Posts
    1,347
    +1
    2

    Ski bogs while turning sharp corners

    My 2000 bogs almost to the point of stalling while turning hard and accellerating. I've also lost close to 200 rpm's on top.

    I think it is fuel related. I would like to hear other folks experiences so I can be sure to get it fixed properly.

    The things I have done but not tested to see if the bog is fixed is:

    Rebuilt carbs

    Installed dual fuel pickups and bypassed fuel switch

    completely drained tank and put 5 fresh gallons in

    Put the bling gas cap on

    Things on the near horizon (this week):

    Gas valves

    Things in the next month if I don't get rid of the bogging and lost rpms

    New pistons and rings.


  2. #2
    spud's Avatar
    Join Date
    Jul 2006
    Location
    Oceanside, California
    Posts
    1,347
    +1
    2
    Oh the Advent is in the project ski. The new flywheel is on the way. I'm going to test it with the Advent first. The flywheel can always go on my third engine.

  3. #3
    spud's Avatar
    Join Date
    Jul 2006
    Location
    Oceanside, California
    Posts
    1,347
    +1
    2
    Someone has got to have an aswer for this.

  4. #4
    mtrager's Avatar
    Join Date
    Jul 2006
    Location
    Orlando, Florida, United States
    Posts
    2,443
    +1
    2
    Spud,

    Anytime I feel a bog it is fuel related.

  5. #5
    spud's Avatar
    Join Date
    Jul 2006
    Location
    Oceanside, California
    Posts
    1,347
    +1
    2
    Thanks,

    Thats my first suspicion as well. I can't think of anything I could have missed through the fuel system now.

    I'm pulling all the electrical powervalves off of it in 15 minutes. I have 2 gas valves here ready to go and the third is coming from Carl as we speak. All green bellows and red springs.

    If that combo doesn't restore her to glory new pistons will go in next week. Then an Advent next month. I'll get her fixed

  6. #6
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Have you removed your fuel flapper yet?Also,check your servo motor and make sure it is working properly.

  7. #7
    spud's Avatar
    Join Date
    Jul 2006
    Location
    Oceanside, California
    Posts
    1,347
    +1
    2
    Hi Woody,

    Servo Checks out with valves turned manually open.

    Flapper door has been gone since 2001

    Clunks and extensions went in in April.

    Dual pickup switch bypass hooked up last night.

    there were not any creased valves and the internal filters were clean in the carbs. The diaphrams seemed a little stretched. Carbs have been rebuilt. $170 for three kits ouch.

    Gas valves going in. Advent in a month or so. Fresh pistons and rings too if this thing doesn't perk up.

  8. #8

    Join Date
    Jan 2006
    Location
    Texas City, Texas
    Posts
    1,249
    +1
    15
    Is your gas tank pressured up? It should hiss when you pull the gas cap off. Lack of pressure on the tank can cause a bog.

    In 2003, I lost the rear main bearing. The symptoms were

    the boat bogged in turns and I lost about 150 rpms.

    the engine had a whine on it when you run it on a hose

    it ran well for about 5-10 minutes before it heated up or ran well if i did not put a serious load on it.

  9. #9
    ABBOTT's Avatar
    Join Date
    Jul 2005
    Location
    Birmingham, AL / Lay Lake
    Posts
    3,736
    +1
    96
    needle/seat sticking?? Even if just one one carb, the whole thing would want to shut down probably?

  10. #10
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    Do you have a return line restictor installed on that ski?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gp1300 bogging down on sharp turns, pump overstuffed?
    By soulraver in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-02-2014, 07:20 AM
  2. WOT bog while turning hard
    By theprophet in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 09-12-2013, 09:09 AM
  3. Ski bogs 500+ rpm in WOT Sweep turns
    By ou812 in forum 4-Tec Performance
    Replies: 5
    Last Post: 11-25-2010, 03:22 PM
  4. ski bogging down
    By nev350 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 05-13-2007, 06:39 AM
  5. Ski Bogging with Advent
    By OCFZR in forum Yamaha PWC Performance (2-stroke)
    Replies: 29
    Last Post: 08-22-2006, 11:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •