Page 1 of 9 1 2 3 ... LastLast
Results 1 to 10 of 81
  1. #1
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471

    first ride w new toys....

    the ski 07 rxp ..

    x charger stock
    e bay intercooler w bleed
    riva ecu w 50
    riva ride plate
    riva intake grate
    filled holes.
    pro plus block offs
    r&d auto drop nozzle
    4 inch intake front into the front air intake in the front of the seat
    gutted stock water box
    flaired j pipe
    through hull
    ported throddle body
    158 riva thermostat
    40 plate heat exchanger
    valve train riva
    finger throddle
    greddy blow off
    stock sponsons lowered
    pump wedge
    inovative o2 guage and boost guage
    15 20 r untouched
    think that is it

    parts pending installeation walbro fuel pump and fuel rail ..anda rude controler ..when i go the next step..looking at my finances..probably a mini rude for now

    only saw 11 psi at 8350 had some cavitation off the line need to look at the seal...but good over all ...definately a little better..than the s3 charger and stock ecu...the plate turned well ..bu did get a bounce ...only tried it netral or maybe 1 bar up ...it was great as long as it didnt start to bounce...once it started the only way i found to get it to stop was to trim down and move forward..then go again tank was about hALf full

    going out again tomarow...w gps...just did alot of stuff over my old set up so the tweaking begins...

    when i can get my camera to talk to my computer ill post pics of how i did stuff
    Last edited by breon; 11-25-2009 at 10:44 PM.


  2. #2
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    Come on spill the beans

  3. #3
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    and...?

  4. #4
    no reverse jayohentran's Avatar
    Join Date
    Mar 2008
    Location
    virginia
    Posts
    543
    +1
    1
    ...so how is it?

  5. #5
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    sorry it sent before i got it finished...had to edit....ill get more up tomarrow gf has been real nice and letting me work all day ...so going to go spend some time with her and ill try again tomarrow morning

  6. #6
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,063
    +1
    790
    Front or rear 4inch?
    What nozzle?
    Get them R's up to 8600
    Good luck!

  7. #7
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by Water4fire View Post
    Front or rear 4inch?
    What nozzle?
    Get them R's up to 8600
    Good luck!
    4" front intake
    Stock 83mm
    I'll tweek his prop accordingly, or let him try another one.

    I'll ride with him tomorrow, and try it out. He may also have a small boost leak.

  8. #8
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    Quote Originally Posted by Water4fire View Post
    Front or rear 4inch?
    What nozzle?
    Get them R's up to 8600
    Good luck!
    water your ski was a big inspiration ....thanks for sharing you information i can only hope for similar results

    just did a bunch of changes...only got about 40 min on the ski...good shake down run ....did the x charger over the s3 charger eventually want a rude 3 ..but may end up with a mini rude and rude controler..in the interum... went to a riva ecu...riva ride plate...and heat exchanger...added the 02 sensor..and boost guage......so got a few things to sort out...it is a front 4 inch..goes into the tube in the front of the seat....and stock nozzle as jason said...just have the r&d auto drop nozzle it is extended like 10 mm...and automatically trims it down when you turn the bars...going to look at the pump in the morning... and see if i can find the cavitation ... thinking the pump seal is pinched...letting air in...it has never cavitated noticalbly before...double check the clamps on the boost tubes...and give it a look over...i was only seeing 11 psi.....when i got it back i noticed the fog tube was left / blown open ..dont think that would be worth 2 psi but maybe..when you combine that with 200 rpm and a little clutch slip....have all new mcmastercar clutch washers ...slip was a little on the low side....check the lines to the boost guage...ect...i was washing the ski flushing it out and i was surprised at how warm the water comming out of the intercooler was even at idle..not hot but warmer thani thought it would be...


    ill get out there with a gps...and see where i am ...and ill try toget some pics up....

    as for the ride plate...worked well in the chop ...wasnt bad today 1 to 2 ft ...feels good but the gps...will tell the tail ..as i said as long as you are on totaly flat water it is great..but if anything gets the front to bounce..it continues..i was able to trim it down a bit ..and move forward for a second ..it would stop and the was able to trim it back up and mor to the rear again ..

    she is not being all she can be still missing things ..ill get it..all fun

  9. #9
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    got out again today in let just say less than ideal conditions for speed....

    but i really like the riva plate in the chop ...it was 1 to 2 for the most part today some 3 ish tracked straight and well....trim down all the way stayed hooked as well as could have been expected...when it wasnt in the air

    in the flattest water avalible today only saw 77.7 ..still not flat by any means

    salt water..tank was 3/4 to 7/8 full water temp was 78 79 air about the same or a few cooler.. trim worked well netral ...still have the wedge for the moment..no bounce..in flatter water..trim neutral....had flat water yesterday no gps

    the hull is compleatly out of the water from the sponsons forward according to jason psycho rxp who was beside me...

    still only seeing 8360 rpm and 11 psi...the machiene shop should have my curved runner exhaust manifold spacers done this week they should be good for 100 to 150 rpm ..have 10...the slip on my charger was on the light side...have new washers going to put them in ...and if that doesnt get me to 8600 and 13 psi need to look at de pitching the prop ..or for boost leaks...and for speed i do have 80 hours on the oem wear ring...maybe an new one might be in order..af seems to stay in the 12 s for the most part would like to see it a litle richer....goes a leaner at idle say 13 13.5 up to about 10 20 percent throddle ..the is back in the 12s ....all the way up ...rude controler can take care of that

    the cavitation is still there a little ..took the pump off this morning the rubber gasket didnt look like it went in quite right last time ..a little silicone..and re installed it ..and better....getting more power in the low end ..prbably causing it ..another issue ..not sure what i need to do there...one thing at a time ...

    my old s3 charger stock ecu and stock plate went 75 76 ish on a good day ..not like today ...

    saw a few mph in crap conditions..i think a good day ill see at least 6 ...there is a few more miles per hour there hoping for 82 ...the acelleration is better...so on the way to being a really fast ski..there is alot more to making a ski go 80 plus than bolting on a bunch of parts....

  10. #10
    KC Blue Thunder's Avatar
    Join Date
    Oct 2007
    Location
    Jacksonville, Florida
    Posts
    2,079
    If you think you might have a boost leak somewhere you might want to invest on this little gadget. It does wonders at finding leaks.
    http://www.siliconeintakes.com/produ...8149c92732ff18

Page 1 of 9 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Just had my first ride on my new GTX
    By gutter in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 05-20-2010, 05:55 PM
  2. first ride on my new skis
    By luckyc1423 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 11-07-2009, 08:04 PM
  3. First Ride With New Skis ??? Questions
    By rickreeves1 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-27-2007, 11:03 AM
  4. New To Board - First Ride Yesterday
    By DaveF in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 03-01-2007, 03:54 PM
  5. first ride of the season tested new 14/19 solas prop
    By daverxp4 in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 04-15-2006, 12:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •