Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Replacing Wear Ring

    Took the pump out of my 06 GTI today to check out the wear ring. First time taking it out and it was probably one of the easiest things Ive done for anyone out there thats worried about doing it. Once I got the impeller housing out it was pretty obvious that it needed to be replaced. I sucked up some rocks this past summer and surprisingly there wasnt much damage from that at all, just seems its worn out. Once the set screws were removed the ring slid right out. No fridge needed and all that. One odd thing to note was it looked like one of the set screws had been forced out. Not sure if when the rocks got sucked up it hit hard against the wear ring and pushed it out but the threads were practically gone and the screw was wedged under the vanturi. Nothing else looked damaged or anything.

    I flipped the wear ring over just to see if it would go back in and the impeller rubbed the wear ring. I kept twisting the ring and finally got it to where the impeller BARELY touched when spinning. Is this normal? Either way, I want to replace the wear ring since the groove is so deep. Another odd thing is the wear ring is only worn on one side. Is this seen very often?



















    Few questions:

    -Is there any need to replace any of the gaskets for the vanturi or the seal between the impeller housing and the jet ski(#8 for the seal btwn housing and jetski in that link below)? They all appeared to be nice and soft still.
    -Is that stupid wear ring really $63??? Is there anywhere else to buy that simple piece of plastic for cheaper? Its a GTI so I looked at #2 in the diagram.
    -Do I need to buy the syn grease for the cone or can I just use marine grease? Can I use Marine grease on the shaft where the impeller slides on also? I plan on getting the seals for the cone just incase.
    -Ive noticed they used yellow lock-tite on every bolt Ive taken off. Dont have yellow lock tite but I have blue. Is that ok?

    http://partsfinder.onlinemicrofiche....=13&A=133&B=13

    Thanks for any help!


  2. #2
    ohh, is this the right impeller removal tool? Figure Ill go ahead and get it in case I ever need it. It doesnt say anything about a GTI.

    http://www.4-tecperformance.com/inde...roducts_id=307

    Does anyone have trouble getting that cone off? Didnt feel like messing with it today but I took the 3 bolts and and tried to tap it side to side. Didnt move at all. Does it take beating it with a rubber mallet?

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    That wear ring looks really bad. Yes, it's normal to be worn on one side more than the other.


    No need to replace the gasket as long as it's not cut or pinched, etc.

    Just pry the cone off with a flat head screw driver. Just keep working it around and it will come off.

    I have the OE wear rings a bit cheaper in the performance store
    http://www.4-tecperformance.com/inde...roducts_id=946

    Here's the tool you need
    http://www.4-tecperformance.com/inde...roducts_id=307

  4. #4
    Thanks Green hulk. The jet ski has around 80 hours on it but I really didnt know what to expect as far as how much it should be worn. First time thing for me. Figured it would have some gouges from the rocks but it really didnt. Just worn.

    Any info on the type of grease to use for the splines+cone(marine grease ok?) and what type of lock tite to use(blue ok)?

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    any marine grade grease is fine. Use blue loc tite

  6. #6
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    how many hr's do you have on that wearring? looks alot like the wear pattern on the rings in my 2 warped plastic pumps i have sitting on the shelf. Im guessing by how far the blade is away from the un worn part that your pump "may" be warped.

  7. #7
    Far as I know thats the stock wear ring and the jet ski has 80 hours on it... So the wear ring should have 80 hours.

    The ring slides right into the housing and I can twist it around no problem. If it was warped I would think the ring wouldnt be 100% round and I wouldnt be able to twist it around in the housing. And when I flipped it around I could twist it till the impeller didnt rub at all. Im thinking the tolerance isnt all that great when they manufacture them. It is a simple piece of plastic.

    Sounds good green hulk. Marine Grease it is.

  8. #8
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    Quote Originally Posted by Jeepster04 View Post
    Far as I know thats the stock wear ring and the jet ski has 80 hours on it... So the wear ring should have 80 hours.

    The ring slides right into the housing and I can twist it around no problem. If it was warped I would think the ring wouldnt be 100% round and I wouldnt be able to twist it around in the housing. And when I flipped it around I could twist it till the impeller didnt rub at all. Im thinking the tolerance isnt all that great when they manufacture them. It is a simple piece of plastic.

    Sounds good green hulk. Marine Grease it is.
    righton... If it's warped youll know cause the ring will be junk in 1 or 2 hrs. Plastic pump are nitorious for warping. I hade to go with an aluminum pump but there was a member that used an SS wear ring and didnt have any more problems.

  9. #9
    Just want to make 100% sure. Is this the correct SS wear ring for the GTI 130?

    http://www.4-tecperformance.com/inde...oducts_id=1205

    Still not decided if Im getting the SS wear ring or the OEM plastic wear ring.

  10. #10
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by Jeepster04 View Post
    Just want to make 100% sure. Is this the correct SS wear ring for the GTI 130?

    http://www.4-tecperformance.com/inde...oducts_id=1205

    Still not decided if Im getting the SS wear ring or the OEM plastic wear ring.

    Yes, that is the correct wear ring.

    Thank you,
    Jerry

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Odd noise after replacing wear ring
    By North49 in forum 4-Tec Performance
    Replies: 23
    Last Post: 10-10-2007, 04:41 PM
  2. Need Help: Replacing Wear Ring on 97 GTX
    By MPower in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-31-2007, 09:27 PM
  3. When to replace wear ring ?
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 10-29-2006, 10:18 PM
  4. When to replace wear ring?
    By HoopsRXT in forum 4-Tec Performance
    Replies: 9
    Last Post: 09-28-2006, 05:54 PM
  5. Finished with replacing wear rings every few hours!
    By RXPDAVID in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-15-2005, 06:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •