Results 1 to 3 of 3
  1. #1
    I want to ride
    Join Date
    Aug 2008
    Location
    Bulgaria / Sofia
    Posts
    56
    +1
    1

    Exclamation Problem with 06' RXP - Engine repair, 2 oil pumps damaged.

    I found the missing parts from the Metal clutch washer and the Needle pins which were all around the engine. >> http://greenhulk.net/forums/showthread.php?t=112286 <<Luckily the engine si ok but both oil pumps have been damaged and mostly the one situated in the PTO cover, it has a lot of marks on it. While the other one next to the oil separator seems to be a bit better but still you can feel a bit of a hold up. What shell I do?


  2. #2
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Usually you must replace both oil pumps and open the engine case to thoroughly clean the case, crank, etc. If you don't open up the engine, very often the engine itself fails (usually throws a rod out the side) within a matter of hours of running it later due to small particles in the engine bearings and oil passages.

    Order two new oil pumps, crack the case and thoroughly clean the engine, reassemble, then either buy a new SC (X chargers are complete and very reasonable price and add performance), or if your SC case and impeller are undamaged (unlikely), you can spend $300 for a new shaft kit, which replaces everything but the SC case halves and impeller.

  3. #3
    I want to ride
    Join Date
    Aug 2008
    Location
    Bulgaria / Sofia
    Posts
    56
    +1
    1
    Thanks for the advice

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 05 RXP with 06 155NA engine... pics inside!
    By b_dolla44 in forum Sea Doo 4Tec Skis
    Replies: 2
    Last Post: 10-18-2010, 10:15 AM
  2. Problems With My RXP
    By W35LEY in forum 4-Tec Performance
    Replies: 19
    Last Post: 07-12-2007, 12:45 PM
  3. Still have a problem with my RXP.....
    By LiquidDI in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-04-2006, 01:18 AM
  4. OMG Problem with my rxp and myself!!!!
    By ADAMBOMB in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-20-2006, 09:55 AM
  5. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •