Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715

    I need help with intake

    is it posible to lose rpms going from a riva 3in to the kaneflex4in with a&d adaptor? Cause it seems like I did lose rpm


  2. #2
    sp_RXP_GR's Avatar
    Join Date
    Oct 2007
    Location
    Greece,Athens
    Posts
    148
    impossible,the problem is somewhere else...

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by sp_RXP_GR View Post
    impossible,the problem is somewhere else...
    I agree!

  4. #4

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    that's what I thought so there is no way I could lose rpms fromthat even if its on wrong witch its not on wrong, can it be cause it was windy or thw water was dirty?

  5. #5

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    can it be the bends

  6. #6
    BlackHawk's Avatar
    Join Date
    Mar 2006
    Location
    AL
    Posts
    961
    +1
    2
    Quote Originally Posted by stevorxp007 View Post
    can it be the bends
    No really bro...check your SC slip

  7. #7
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    Quote Originally Posted by BlackHawk View Post
    No really bro...check your SC slip
    +1 check the slip. what are your rpm's and how many did you lose?

  8. #8
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    +1, What air filter are you running?

  9. #9
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by jp1300r View Post
    +1, What air filter are you running?
    Sounds like a shop rag

  10. #10
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by bigdaddyRXP View Post
    Sounds like a shop rag
    No kidding..

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help with rear exhaust and intake ribbon on 2012 SHO Cruiser
    By Dragdaddy71 in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 04-28-2013, 05:21 PM
  2. Need help with selection of intake grate
    By B.L.P. in forum 4-Tec Performance
    Replies: 1
    Last Post: 10-04-2012, 04:28 PM
  3. Need help with Intake
    By JonnyRXT in forum 4-Tec Performance
    Replies: 12
    Last Post: 03-16-2008, 05:57 PM
  4. Need help with pump issue
    By Flyer in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-23-2006, 05:40 PM
  5. Need help with 04 S.C. rebuild
    By Turbo Todd in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-10-2006, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •