Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715

    need help asap please

    i need help asap please i have a friend that has a 2007 gtxlt and he has a problem as he is riding there is no problem but when he lets go of the gas it cuts out does anyone know what this is?


  2. #2

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715

    Smile

    can anyone help me

  3. #3
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Try brand new spark plugs. First.

  4. #4

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    i dont think its the spark plug. what else can it be?

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by jp1300r View Post
    Try brand new spark plugs. First.
    I agree! Start with the spark plugs first.

  6. #6
    KC Blue Thunder's Avatar
    Join Date
    Oct 2007
    Location
    Jacksonville, Florida
    Posts
    2,079
    I havent had that problem with mine.... Whats else is it doing.... I mean is it throwing a code, is it completely shutting off when he lets go of the throttle?
    Is it sputtering, we need some more info dude. I agree with Jerry check the plugs and all connections.

  7. #7

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    he says when he lets go of the gas it just turns off completely

  8. #8
    KC Blue Thunder's Avatar
    Join Date
    Oct 2007
    Location
    Jacksonville, Florida
    Posts
    2,079
    Will it stay on with the hose connected to it (flushing) or does he have to have the throttle pulled to be able to run. Does it Idle by itself or does it sputter and then shut off.

  9. #9

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    no it will not run on idle i thought maybe it was the battery but he said its not he change it

  10. #10

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    he also said he plugged it to the car battery and it did the same thing

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Starter Bendix Washers? Need Help ASAP please????
    By thompsdw in forum 4-Tec Performance
    Replies: 26
    Last Post: 06-11-2017, 05:31 PM
  2. Need Help ASAP PLEASE!
    By ajharbin in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 03-22-2014, 04:12 PM
  3. Need everyones help ASAP (PLEASE)
    By Markb47 in forum Open Discussion
    Replies: 15
    Last Post: 09-18-2008, 07:17 AM
  4. Need everyones help ASAP (PLEASE)
    By Markb47 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 09-14-2008, 04:12 PM
  5. need help asap!!! please
    By nonvtecdaturbo in forum Polaris Open Discussion
    Replies: 23
    Last Post: 12-12-2006, 08:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •