Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28
  1. #1
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46

    AF with Riva ECU

    Can any1 tell me what sort of AF readings they are getting with a Riva ECU 50 injectors and stock fuel pressure at Idle??? Thanks R88


  2. #2
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    high 12 low 13 tp about 20% throddle mid 12 running

  3. #3
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6
    I was pretty consistent 13.2-4

  4. #4
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by breon View Post
    high 12 low 13 tp about 20% throddle mid 12 running
    Nice 1 thanks, Just trying to help Repsol tune his turbo RXT.

    He has the Duel reg setup and rail from TurboTec, That all appears to be working as it should but he still has high 11s at idle with the first reg (idle pressure) set at 30psi!! So im not sure his AF gauge is working right. He only had a couple points higher at 50psi. Any thoughts any1 else??? R88

  5. #5
    richrxp's Avatar
    Join Date
    Jun 2006
    Location
    Netherlands
    Posts
    949
    +1
    1
    Quote Originally Posted by R88ory RXP View Post
    Nice 1 thanks, Just trying to help Repsol tune his turbo RXT.

    He has the Duel reg setup and rail from TurboTec, That all appears to be working as it should but he still has high 11s at idle with the first reg (idle pressure) set at 30psi!! So im not sure his AF gauge is working right. He only had a couple points higher at 50psi. Any thoughts any1 else??? R88
    Can be two things

    Afr gauge is bad,did he test it in open air should read 20.9 .

    Injectors are bad,this way you get strange afr readings.

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Do not run a boost line to the 1:1 with the Begi set-up.

    My base PSI at idle is 24-25 AFR 13.5

  7. #7

    Join Date
    Feb 2008
    Location
    novwhere
    Posts
    597
    Quote Originally Posted by richrxp View Post
    Can be two things

    Afr gauge is bad,did he test it in open air should read 20.9 .

    Injectors are bad,this way you get strange afr readings.
    Hello guys,

    If the injector(s) bad sure engine damage or can't work on WOT. But this is work and WOT position I can setup AFR 11,7-11,9

    I think RIVA ECU very save. When I take in Seadoo centre ecu with 60lb injectors and big charger AFR at idle was 13,3.

  8. #8

    Join Date
    Feb 2008
    Location
    novwhere
    Posts
    597
    Quote Originally Posted by beerdart View Post
    Do not run a boost line to the 1:1 with the Begi set-up.

    My base PSI at idle is 24-25 AFR 13.5
    hi,

    when I set-up idle AFR I was connected vacum to BEGI ONLY and ALL screws was unscrewed from RRFPR and BEGI and minimum psi was 27 psi on gauge in fuel rail. I think ( maybe ) fuel back hole in tank adapter too small for fuel rail system. I think 2-3 mm but sure not too much.

  9. #9
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by beerdart View Post
    Do not run a boost line to the 1:1 with the Begi set-up.

    My base PSI at idle is 24-25 AFR 13.5
    Yes He did have a line to the RRFPR but now he doesnt. I have talked him through how to set it all up and its working on the hose apart from the AF is far to rich at idle. It dont make no sense as he still seeing under 12 at 30psi fuel.

    Im starting to think it could be your AF setup Peter. R88

  10. #10

    Join Date
    Feb 2008
    Location
    novwhere
    Posts
    597

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TPS reset with Riva ECU?
    By Vern in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-04-2009, 02:33 PM
  2. RRFPR with riva ecu
    By BoostedH23a1 in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-15-2009, 07:32 AM
  3. Need help with RIVA ECU
    By elbchecker in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-26-2008, 03:24 PM
  4. 05' No warranty left, need help with RIVA ecu activation
    By MIARider in forum 4-Tec Performance
    Replies: 7
    Last Post: 03-21-2008, 09:55 PM
  5. Green wheel with Riva ECU?
    By DarthAWM in forum 4-Tec Performance
    Replies: 12
    Last Post: 03-03-2008, 07:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •