Results 1 to 3 of 3
  1. #1
    Big K's son KeithKman's Avatar
    Join Date
    Dec 2006
    Location
    Southern California
    Posts
    1,735

    2001 Tahoe loose shifter

    2001 LT Tahoe. The shifter feels loose and real light when selecting a gear. How would I go about tightening this to make it more stiff? Is this a common problem on Tahoes?


  2. #2
    Banned User
    Join Date
    May 2008
    Location
    Lake Havasu
    Posts
    2,924
    +1
    27
    I have a 2001 Yukon, same thing, and have never heard of this problem. Mine's a 2wd.
    I'd take it to a shop though. Maybe the linkage is just loose.

    Those Tahoe/Yukon's are bullet proof. Mine has the 5.3 liter engine, 119,000 miles, and runs like a champ. Just had new tires put on yesterday, and the brakes, with 40,000 miles on them, still are at 90%. The mechanic said the brakes in these things last forever.

  3. #3
    Big K's son KeithKman's Avatar
    Join Date
    Dec 2006
    Location
    Southern California
    Posts
    1,735
    Quote Originally Posted by iflyems View Post
    I have a 2001 Yukon, same thing, and have never heard of this problem. Mine's a 2wd.
    I'd take it to a shop though. Maybe the linkage is just loose.

    Those Tahoe/Yukon's are bullet proof. Mine has the 5.3 liter engine, 119,000 miles, and runs like a champ. Just had new tires put on yesterday, and the brakes, with 40,000 miles on them, still are at 90%. The mechanic said the brakes in these things last forever.
    I agree these tings are tough. I have the 5.3 also. 126k miles. I love it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Polaris Gensis, electronic shifter
    By mixx911 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 10-29-2007, 11:05 PM
  2. loosing control with RXP
    By mrracing in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-17-2005, 12:26 AM
  3. Set Button came off and loosing take off speed!
    By Compwhiz82 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-11-2005, 02:03 PM
  4. Overwear or K&N pre-filters loose water resistance
    By Kinchyle in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-24-2005, 10:27 PM
  5. A little OT: why do my tie-downs keep coming loose?
    By ToeSurf in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-01-2005, 11:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •