Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    rxp12's Avatar
    Join Date
    Jan 2008
    Location
    NC
    Posts
    113

    I need help with riva 3 inch filter!

    guys i think im screwed. somehow the bottom bolt on the filter tube mounting bracket, the head has been rounded off and the e8 socket will not fit!! i have ripped everything oem out of the ski and now im worried over what was supposed to be a very simple installation. im not very good at mechanics and i need some help. am i going to have to take this to dealer? what do i do??? thanks guys.


  2. #2
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    im not sure what bolt your talking about but when im dealing with stripped bolts i try and tap a smaller socket regular or E socket what ever you can get on that that fits the tightest.

  3. #3
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61
    I found out this summer that my filter was not connected to the bracket. I don't know how long it was like this and I still have not fixed it. I ride pretty hard some days and do a lot of wave jumpimg. It is very tight and does not apper that it's moving so I have left it alone. You can take it to a dealer but if it feels secure why pay them.

  4. #4
    rxp12's Avatar
    Join Date
    Jan 2008
    Location
    NC
    Posts
    113
    Quote Originally Posted by sportsterme View Post
    im not sure what bolt your talking about but when im dealing with stripped bolts i try and tap a smaller socket regular or E socket what ever you can get on that that fits the tightest.
    on the riva kit im installing the bracket the connects the filter tube to the oil filler tube on the motor and i have already tryed a regular socket its not working either.

  5. #5
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    Quote Originally Posted by rxp12 View Post
    on the riva kit im installing the bracket the connects the filter tube to the oil filler tube on the motor and i have already tryed a regular socket its not working either.

    find a size that just a tade smaller and tap it on with a hammer. (ex) say a 10mm bolt strips ill tap a 3/8 socket on toget it off.

  6. #6
    rxp12's Avatar
    Join Date
    Jan 2008
    Location
    NC
    Posts
    113
    Quote Originally Posted by sportsterme View Post
    find a size that just a tade smaller and tap it on with a hammer. (ex) say a 10mm bolt strips ill tap a 3/8 socket on toget it off.
    yea the problem is its at the front of the motor i can bareley get one hand in there yet alone two with a hammer lol

  7. #7
    DPG98GSXL's Avatar
    Join Date
    Feb 2007
    Location
    East Tennessee
    Posts
    559
    +1
    23
    Quote Originally Posted by rxp12 View Post
    guys i think im screwed. somehow the bottom bolt on the filter tube mounting bracket, the head has been rounded off and the e8 socket will not fit!! i have ripped everything oem out of the ski and now im worried over what was supposed to be a very simple installation. im not very good at mechanics and i need some help. am i going to have to take this to dealer? what do i do??? thanks guys.
    Try a 1/4" box end wrench on it...I had a similar problem on a SC this year and Danny recommended to try that....Get a good bite on it and it will break it loose....It worked.....Then when you replace it, use a standard Hex head on it so it will be easier next time....I think it is Metric thread..
    I did a Riva L1 on my buddys 04Rxp....I know the bolt you are talking about...It is a Beotch to get too....Be patient....

    Hope that helps
    DG

  8. #8
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    Quote Originally Posted by rxp12 View Post
    yea the problem is its at the front of the motor i can bareley get one hand in there yet alone two with a hammer lol
    if its the 2 bolts that connect the bracket to the motor,you won't need a hammer....try a small vice grip,if not:

    http://www.sears.com/shc/s/p_10153_1...0070515x00001c#

    good luck!!

    ps:i've never installed one,but that riva 3 inch filter install is suppossed to be a royal PIA.

  9. #9
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    I have run the 3 inch without the bracket as stated.
    in fact on my T-X I was running a custom 4 inch carbon fiber setup without a filter and it did not have bracket to hold it in place and never had any issues.

    You should be able to get the smallest vice grips you can to break that bolt loose.

  10. #10
    http://www.sears.com/shc/s/p_10153_1...0070515x00001c


    This was exactly what I was gonna recommend. had a problem with valve cover bolts rusted and this got them out pretty easy.

    Try the vice grip and if it doesn't work then the above should.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need help with Riva Endurance kit
    By inchadeboca in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 08-01-2008, 06:35 AM
  2. Need help with RIVA ECU
    By elbchecker in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-26-2008, 03:24 PM
  3. 05' No warranty left, need help with RIVA ecu activation
    By MIARider in forum 4-Tec Performance
    Replies: 7
    Last Post: 03-21-2008, 09:55 PM
  4. need help with riva rear exaust guys
    By bob1988 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-17-2007, 10:17 PM
  5. Need Help With Riva Stage I Install
    By Flynfox in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 12-04-2006, 10:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •