Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Jun 2005
    Location
    lakeland florida
    Posts
    36

    it's finally done !!!!

    well after sitting in the sea doo shop for f@#@$ ever ( three months because sea doo parts take forever ) I'm picking it up this afternoon and going to try out the riva stage 2 they put on it , hopefully everything goes ok. :P :P


  2. #2
    Good Luck

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,994
    +1
    1,903
    Congrats! We can't wait to hear your results.

  4. #4
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    73.9

  5. #5

    Join Date
    Jun 2005
    Location
    lakeland florida
    Posts
    36
    I hope 73.9 . I have a new garmin gps 72 so we will see!

  6. #6

    Join Date
    Jun 2005
    Location
    lakeland florida
    Posts
    36
    ok today I took it out for the first time with the stage 2, how crappy it ran !!!!! first off it would not go over 7250 rpms, and on gps would not go over 60.9 miles an hour, checked everything could not find anything wrong with anything, like loose hoses or something in the impellar, what could be wrong? but please keep in mind riva sent the wrong solas , I have the 14/19 on untill they send me the 15/20, but that would'nt change it that much would it?

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,994
    +1
    1,903
    is your supercharger impeller rubbing the housing?

  8. #8

    Join Date
    Jun 2005
    Location
    lakeland florida
    Posts
    36
    god I hope not I'm going to take it back to the shop and tell them here you go you built it you make it right, bone stock on gps it would go 67, I was so imbarassed with it today, everybody came out to see it at the lake today , I dont know much about jet skis , hopefully they will make it right! I wished you lived near me green hulk!!!!!!!!!!!!!

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,994
    +1
    1,903
    Well, the two things I think it could be are the supercharger impeller is rubbing the housing, or you have a boost leak thru the plumbing for the intercooler.

    Hopefully it's just a boos leak.

  10. #10

    Join Date
    Jun 2005
    Location
    lakeland florida
    Posts
    36
    two things, would a boost leak cause it to only reach 7250 rpm and also what about the 14/19 impellar?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 GP1200 triple finally done! Well almost!
    By krispaintballz in forum Yamaha Old School Skis
    Replies: 1004
    Last Post: 12-15-2015, 02:06 AM
  2. 98 SLTX & 99 X-45 Finally Done!
    By 32DegH2O in forum Polaris Projects
    Replies: 25
    Last Post: 06-27-2008, 05:30 PM
  3. Finally done with training
    By nitro rxp in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 09-02-2006, 05:47 PM
  4. Final Template DONE: custom Rectifier Bracket PICTURES
    By rxpblast in forum 4-Tec Performance
    Replies: 67
    Last Post: 03-26-2006, 04:01 PM
  5. finally done
    By PAINKILLER in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-19-2005, 03:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •