Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1

    Supercharger Corrosion locked s/c to engine

    Hey guys have had a drive shaft failure spline has stripped off(due to broken front engine mount) thats fine easy to fix . Problem lies with getting the supercharger off to get to the clip underneath , i have got the 3 torx bolts off holding s/c to engine.
    However the s/c is covered in corrosion have tried as hard as i dear with a mallet and wood to get it to budge, guessing the corrosion is inside the seal of the engine/supercharger.
    Any suggestions on how to get the s/c off without breaking any of the cast

    Skis a 03 Gtx ltd

    Cheers guys
    Scotty


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Try rotating housing it to break it loose.

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Hi Scotty, you need to spray some penetrating oil onto the snout of the supercharger. Spray some every hour or so during the day. Keep trying to rock the supercharger back and forth until it breaks free. It will eventually break free. Just keep spraying!

    You might consider replacing the stock front mount with one of these
    http://www.4-tecperformance.com/inde...roducts_id=501

  4. #4
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Have you tried rotating the charger back and forthe ?

    Damn I type slow.
    Last edited by speedskixp; 12-15-2009 at 05:40 PM. Reason: too slow

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Quote Originally Posted by speedskixp View Post
    Have you tried rotating the charger back and forthe ?

    Damn I type slow.

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Steve 1 Jim 1

  7. #7
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by beerdart View Post
    Steve 1 Jim 1
    true.

  8. #8
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    If rocking it back and forth doesn't work, see diagram below for detailed instructions.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	SC Removal.JPG 
Views:	58 
Size:	17.0 KB 
ID:	163964  

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524

  10. #10
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    i also have a 2003 GTX SC
    use a mirror to make triple sure you actually removed the correct 3 mounting bolts. its really easy to remove one of the SC housing bolts by accident.
    then,
    first try to get the Sc to rotate, i had to use a block of wood and a hammer to tap on itget it to spin at first, after an hour of back and forth, adding penetrating oil frequently, it rotated by hand, but still a bit hard.
    then i was able to wedge 2 peices of wood btw the SC and the engine, and then drive a 3rd wedge btw the 2 peices of wood, while i was wedging the Sc off i was also rotating it back and forth.
    eventually you will be able to see more and more of the SC snout
    then keep lubricating it...
    it took me about 2 hours to get it off.
    clean it up real good and lube the snout before you reinstall. or replace with a new SC, the red SC was known to flake off real bad and corrode.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 951 DI exhaust manifold failure - leads to engine lock-up
    By Pamlico in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-29-2012, 09:48 PM
  2. loads of pics from interfaces to engines
    By seadoomaster in forum HSR-Benelli - Hydrospace PWC
    Replies: 9
    Last Post: 06-21-2008, 01:31 PM
  3. driveshaft to engine coupler
    By jvhenry in forum Polaris Open Discussion
    Replies: 6
    Last Post: 04-16-2008, 10:53 AM
  4. hose from exhaust to engine??
    By wavehummer in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-30-2006, 10:27 PM
  5. Water in hull up to engine cover
    By jonstephens in forum 4-Tec Performance
    Replies: 20
    Last Post: 09-25-2005, 12:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •