Results 1 to 5 of 5
  1. #1

    Join Date
    Aug 2009
    Location
    CA
    Posts
    237

    Started engine for first time, questions?

    2005 RXP, just fired up the new engine for the first time. Fired right up. Let it run for about 5 secs without the hose then shut it down to check the oil. I put in 4.5 quarts before I started it and it is barely at the first line on the dipstick, should I ad more a wait a little to see if the level comes up from sitting? Then I started it and turned on the hose to let it run for about 3 mins. It smoked pretty good for the first minute, I assume it is just from being newly installed. Now when I let it run it is idling at 2500rpm. Then when I rev it a little to see if the revs go down to 1800rpm it sits at 3000rpm? Any ideas what could cause this?


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by bryanw80 View Post
    2005 RXP, just fired up the new engine for the first time. Fired right up. Let it run for about 5 secs without the hose then shut it down to check the oil. I put in 4.8 quarts before I started it and it is barely at the first line on the dipstick, should I ad more a wait a little to see if the level comes up from sitting? Then I started it and turned on the hose to let it run for about 3 mins. It smoked pretty good for the first minute, I assume it is just from being newly installed. Now when I let it run it is idling at 2500rpm. Then when I rev it a little to see if the revs go down to 1800rpm it sits at 3000rpm? Any ideas what could cause this?
    Throttle cable to tight or vacuum leak.

  3. #3

    Join Date
    Aug 2009
    Location
    CA
    Posts
    237
    After starting and letting it run for 3 minutes several times(waited for engine to cool off in between) it now is idling right at 1800rpm so I think that part is good. Now I am just wondering about the oil level. I put in 4.5 quarts because it was a new dry engine. After waiting 30 seconds after engine is off and checking the oil level it is a little bellow the mid point on the dip stick. Should I add a little more even though my seadoo manual says the oil capacity is 4.1 quarts and I am already at about 4.5 quarts?

  4. #4
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by bryanw80 View Post
    After starting and letting it run for 3 minutes several times(waited for engine to cool off in between) it now is idling right at 1800rpm so I think that part is good. Now I am just wondering about the oil level. I put in 4.5 quarts because it was a new dry engine. After waiting 30 seconds after engine is off and checking the oil level it is a little bellow the mid point on the dip stick. Should I add a little more even though my seadoo manual says the oil capacity is 4.1 quarts and I am already at about 4.5 quarts?
    YOu need to get it on the water and let it warm up and then check it.
    Easier to add then take it out.
    If you have 4.5 qts in it i would warm it up in the water and then check it.

  5. #5

    Join Date
    Aug 2009
    Location
    CA
    Posts
    237
    You think I should take a quart out now and then in the spring when I am able to water test it just bring oil to add? I don't want to get out on the water and have to much like you said about being easier to add oil.



    Quote Originally Posted by skoepp View Post
    YOu need to get it on the water and let it warm up and then check it.
    Easier to add then take it out.
    If you have 4.5 qts in it i would warm it up in the water and then check it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 06-22-2013, 03:30 PM
  2. Question about running in water for first time
    By shaun23a11en in forum Yamaha Old School Skis
    Replies: 6
    Last Post: 05-19-2012, 04:49 PM
  3. 2003 GTX SC question for first time owner
    By Jean-Paul in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 01-25-2010, 01:54 PM
  4. 2003 GTX SC question for first time owner
    By Jean-Paul in forum 4-Tec Performance
    Replies: 2
    Last Post: 01-25-2010, 10:55 AM
  5. Starting new engine for first time.
    By bryanw80 in forum 4-Tec Performance
    Replies: 11
    Last Post: 12-15-2009, 11:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •